Bug 164094 - If an animation's keyframes affect stacking context properties, create stacking context while the animation is running
Summary: If an animation's keyframes affect stacking context properties, create stacki...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords:
: 66341 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-10-27 16:35 PDT by Simon Fraser (smfr)
Modified: 2016-10-27 20:26 PDT (History)
7 users (show)

See Also:


Attachments
Patch (22.51 KB, patch)
2016-10-27 16:39 PDT, Simon Fraser (smfr)
dino: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2016-10-27 16:35:28 PDT
If an animation's keyframes affect stacking context properties, create stacking context while the animation is running
Comment 1 Simon Fraser (smfr) 2016-10-27 16:39:52 PDT
Created attachment 293077 [details]
Patch
Comment 2 Simon Fraser (smfr) 2016-10-27 16:40:30 PDT
*** Bug 66341 has been marked as a duplicate of this bug. ***
Comment 3 Dean Jackson 2016-10-27 17:03:47 PDT
Comment on attachment 293077 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=293077&action=review

> Source/WebCore/page/animation/CSSPropertyAnimation.cpp:641
> -        dst->setOpacity(blendFunc(anim, (fromOpacity == 1) ? 0.999999f : fromOpacity, b->opacity(), progress));
> +        dst->setOpacity(blendFunc(anim, a->opacity(), b->opacity(), progress));

Glad to see this go.

> Source/WebCore/page/animation/CompositeAnimation.cpp:344
> +            blendedStyle->setZIndex(0);

It would be nice if there was a more obvious way to mark as needing a stacking context.
Comment 4 Simon Fraser (smfr) 2016-10-27 20:26:11 PDT
https://trac.webkit.org/changeset/208025