Bug 163940 - Enable SDPProcessor for Mac bots
Summary: Enable SDPProcessor for Mac bots
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: youenn fablet
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-25 06:42 PDT by youenn fablet
Modified: 2016-10-26 09:49 PDT (History)
5 users (show)

See Also:


Attachments
Patch (52.46 KB, patch)
2016-10-25 06:49 PDT, youenn fablet
no flags Details | Formatted Diff | Diff
Patch (52.46 KB, patch)
2016-10-25 08:45 PDT, youenn fablet
no flags Details | Formatted Diff | Diff
Patch (53.07 KB, patch)
2016-10-25 08:53 PDT, youenn fablet
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews107 for mac-yosemite-wk2 (1.56 MB, application/zip)
2016-10-25 10:19 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews101 for mac-yosemite (924.12 KB, application/zip)
2016-10-25 10:22 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews114 for mac-yosemite (1.70 MB, application/zip)
2016-10-25 10:39 PDT, Build Bot
no flags Details
Patch (442.60 KB, patch)
2016-10-26 05:20 PDT, youenn fablet
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews101 for mac-yosemite (900.08 KB, application/zip)
2016-10-26 06:19 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews104 for mac-yosemite-wk2 (1.15 MB, application/zip)
2016-10-26 06:23 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews114 for mac-yosemite (1.70 MB, application/zip)
2016-10-26 06:29 PDT, Build Bot
no flags Details
Patch (41.84 KB, patch)
2016-10-26 07:02 PDT, youenn fablet
no flags Details | Formatted Diff | Diff
Patch for landing (41.99 KB, patch)
2016-10-26 09:13 PDT, youenn fablet
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description youenn fablet 2016-10-25 06:42:23 PDT
This is currently activated for GTK bots only
Comment 1 youenn fablet 2016-10-25 06:49:47 PDT
Created attachment 292749 [details]
Patch
Comment 2 youenn fablet 2016-10-25 08:45:04 PDT
Created attachment 292756 [details]
Patch
Comment 3 youenn fablet 2016-10-25 08:53:15 PDT
Created attachment 292759 [details]
Patch
Comment 4 Build Bot 2016-10-25 10:19:22 PDT
Comment on attachment 292759 [details]
Patch

Attachment 292759 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.webkit.org/results/2368554

New failing tests:
fast/mediastream/RTCPeerConnection-setRemoteDescription-offer.html
fast/mediastream/RTCPeerConnection-remotely-assigned-transceiver-mid.html
fast/mediastream/RTCPeerConnection-media-setup-two-dialogs.html
fast/events/constructors/media-stream-event-constructor.html
fast/mediastream/RTCPeerConnection-media-setup-single-dialog.html
fast/mediastream/RTCPeerConnection-setLocalDescription-offer.html
Comment 5 Build Bot 2016-10-25 10:19:25 PDT
Created attachment 292771 [details]
Archive of layout-test-results from ews107 for mac-yosemite-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews107  Port: mac-yosemite-wk2  Platform: Mac OS X 10.10.5
Comment 6 Build Bot 2016-10-25 10:22:11 PDT
Comment on attachment 292759 [details]
Patch

Attachment 292759 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.webkit.org/results/2368591

New failing tests:
fast/events/constructors/media-stream-event-constructor.html
Comment 7 Build Bot 2016-10-25 10:22:13 PDT
Created attachment 292772 [details]
Archive of layout-test-results from ews101 for mac-yosemite

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews101  Port: mac-yosemite  Platform: Mac OS X 10.10.5
Comment 8 Build Bot 2016-10-25 10:39:55 PDT
Comment on attachment 292759 [details]
Patch

Attachment 292759 [details] did not pass mac-debug-ews (mac):
Output: http://webkit-queues.webkit.org/results/2368628

New failing tests:
fast/events/constructors/media-stream-event-constructor.html
Comment 9 Build Bot 2016-10-25 10:39:58 PDT
Created attachment 292774 [details]
Archive of layout-test-results from ews114 for mac-yosemite

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews114  Port: mac-yosemite  Platform: Mac OS X 10.10.5
Comment 10 youenn fablet 2016-10-26 05:20:17 PDT
Created attachment 292916 [details]
Patch
Comment 11 Build Bot 2016-10-26 06:19:40 PDT
Comment on attachment 292916 [details]
Patch

Attachment 292916 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.webkit.org/results/2376134

New failing tests:
fast/events/constructors/media-stream-event-constructor.html
Comment 12 Build Bot 2016-10-26 06:19:43 PDT
Created attachment 292920 [details]
Archive of layout-test-results from ews101 for mac-yosemite

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews101  Port: mac-yosemite  Platform: Mac OS X 10.10.5
Comment 13 Build Bot 2016-10-26 06:23:02 PDT
Comment on attachment 292916 [details]
Patch

Attachment 292916 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.webkit.org/results/2376140

New failing tests:
fast/events/constructors/media-stream-event-constructor.html
Comment 14 Build Bot 2016-10-26 06:23:05 PDT
Created attachment 292921 [details]
Archive of layout-test-results from ews104 for mac-yosemite-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews104  Port: mac-yosemite-wk2  Platform: Mac OS X 10.10.5
Comment 15 Build Bot 2016-10-26 06:29:40 PDT
Comment on attachment 292916 [details]
Patch

Attachment 292916 [details] did not pass mac-debug-ews (mac):
Output: http://webkit-queues.webkit.org/results/2376144

New failing tests:
fast/events/constructors/media-stream-event-constructor.html
Comment 16 Build Bot 2016-10-26 06:29:43 PDT
Created attachment 292922 [details]
Archive of layout-test-results from ews114 for mac-yosemite

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews114  Port: mac-yosemite  Platform: Mac OS X 10.10.5
Comment 17 youenn fablet 2016-10-26 07:02:52 PDT
Created attachment 292925 [details]
Patch
Comment 18 Eric Carlson 2016-10-26 08:35:13 PDT
Comment on attachment 292925 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=292925&action=review

> LayoutTests/ChangeLog:7
> +        Reviewed by NOBODY (OOPS!).
> +

A comment about why the tests all fail, and maybe a bug number for fixing that, would be useful.
Comment 19 youenn fablet 2016-10-26 09:13:48 PDT
Created attachment 292933 [details]
Patch for landing
Comment 20 youenn fablet 2016-10-26 09:15:25 PDT
Thanks for the review.

> > LayoutTests/ChangeLog:7
> > +        Reviewed by NOBODY (OOPS!).
> > +
> 
> A comment about why the tests all fail, and maybe a bug number for fixing
> that, would be useful.

I added a comment.
I did not add any bug number since it is not clear whether the tests are wrong or the implementation is. Probably both in fact :)
Comment 21 WebKit Commit Bot 2016-10-26 09:49:14 PDT
Comment on attachment 292933 [details]
Patch for landing

Clearing flags on attachment: 292933

Committed r207901: <http://trac.webkit.org/changeset/207901>
Comment 22 WebKit Commit Bot 2016-10-26 09:49:19 PDT
All reviewed patches have been landed.  Closing bug.