Add convenience function that combines WTF::visit(...) with WTF::makeVisitor(...)
Created attachment 292133 [details]
I went with WTF::switchOn(...) for this, but other names that were considered were:
My top two favorites were switchOn(...) and match(...).
Committed r207627: <http://trac.webkit.org/changeset/207627>