Bug 163642 - [Xcode] JavaScriptCore fails to build when CLANG_WARN_DOCUMENTATION_COMMENTS is enabled
Summary: [Xcode] JavaScriptCore fails to build when CLANG_WARN_DOCUMENTATION_COMMENTS ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: Safari Technology Preview
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: mitz
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2016-10-18 19:09 PDT by mitz
Modified: 2016-10-19 10:41 PDT (History)
7 users (show)

See Also:


Attachments
Enable and address documentation warnings (15.92 KB, patch)
2016-10-18 19:17 PDT, mitz
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2016-10-18 19:09:15 PDT
The compiler doesn’t like some of the documentation comments in the headers.
Comment 1 mitz 2016-10-18 19:17:14 PDT
Created attachment 292025 [details]
Enable and address documentation warnings
Comment 2 WebKit Commit Bot 2016-10-18 19:19:30 PDT
Attachment 292025 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/API/JSValueRef.h:96:  The parameter name "value" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/API/JSContextRefInternal.h:53:  The parameter name "runLoop" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/API/JSWeakObjectMapRefPrivate.h:67:  The parameter name "map" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/API/JSWeakObjectMapRefPrivate.h:67:  The parameter name "object" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/API/JSContextRefPrivate.h:88:  The parameter name "group" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/API/JSContextRefPrivate.h:88:  The parameter name "callback" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/API/JSContextRefPrivate.h:95:  The parameter name "group" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 7 in 11 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 WebKit Commit Bot 2016-10-19 10:21:11 PDT
Comment on attachment 292025 [details]
Enable and address documentation warnings

Clearing flags on attachment: 292025

Committed r207542: <http://trac.webkit.org/changeset/207542>
Comment 4 WebKit Commit Bot 2016-10-19 10:21:15 PDT
All reviewed patches have been landed.  Closing bug.
Comment 5 mitz 2016-10-19 10:41:31 PDT
<rdar://problem/27816514>