Bug 162938 - Properly kill web processes in the launching state
Summary: Properly kill web processes in the launching state
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Anders Carlsson
URL:
Keywords:
: 136012 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-10-04 14:38 PDT by Anders Carlsson
Modified: 2016-10-04 15:50 PDT (History)
2 users (show)

See Also:


Attachments
Patch (9.46 KB, patch)
2016-10-04 14:41 PDT, Anders Carlsson
thorton: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Carlsson 2016-10-04 14:38:36 PDT
Properly kill web processes in the launching state
Comment 1 Anders Carlsson 2016-10-04 14:41:39 PDT
Created attachment 290648 [details]
Patch
Comment 2 Tim Horton 2016-10-04 15:41:29 PDT
Comment on attachment 290648 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=290648&action=review

> Source/WebKit2/UIProcess/WebPageProxy.cpp:-2355
> -    // FIXME: A client can terminate the page at any time, so we should do something more meaningful than assert and fall apart in release builds.

Nice.
Comment 3 Anders Carlsson 2016-10-04 15:43:30 PDT
Committed r206789: <http://trac.webkit.org/changeset/206789>
Comment 4 Anders Carlsson 2016-10-04 15:43:53 PDT
*** Bug 136012 has been marked as a duplicate of this bug. ***
Comment 5 Tim Horton 2016-10-04 15:50:08 PDT
<rdar://problem/27867830>