Bug 16282 - Repaint issues with scrollable iframe with an element floating over the top.
Summary: Repaint issues with scrollable iframe with an element floating over the top.
Status: RESOLVED DUPLICATE of bug 5909
Alias: None
Product: WebKit
Classification: Unclassified
Component: Frames (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords: HasReduction, YahooBug
Depends on:
Blocks:
 
Reported: 2007-12-03 16:57 PST by darren
Modified: 2007-12-04 01:44 PST (History)
0 users

See Also:


Attachments
promised attachment..... (1.22 KB, text/html)
2007-12-03 16:59 PST, darren
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description darren 2007-12-03 16:57:47 PST
If the document includes an iframe that has scrollable content in it, and the iframe has a rule that
makes it's body element's background a color (e.g. body { background: #ffffff; }  *and* the iframe
has something that floats over it (e.g. think popup menu on the main document ), when the iframe
is scrolled, the floating element's pixels are scattered all over the underlying iframe.

will attach a small test-case that illustrates the issue.
Comment 1 darren 2007-12-03 16:59:02 PST
Created attachment 17690 [details]
promised attachment.....
Comment 2 mitz 2007-12-03 17:11:55 PST

*** This bug has been marked as a duplicate of 5909 ***