Bug 16278 - Browser gets caught in a redirect loop
Summary: Browser gets caught in a redirect loop
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Evangelism (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.viewpoint.com/technologies...
Keywords: InRadar, NeedsReduction
Depends on:
Blocks:
 
Reported: 2007-12-03 06:01 PST by Sebastian Soyka
Modified: 2008-07-01 02:53 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Soyka 2007-12-03 06:01:56 PST
Hello,

this is a reproducible problem.
When going to tht URL I immediately get directed to another url starting with www. viewpoint.com, and the page reloads eternally, thus cluttering up the browser's history.
Comment 1 David Kilzer (:ddkilzer) 2007-12-03 09:53:19 PST
Confirmed with local debug build of WebKit r28320 with Safari 3.0.4 (523.12) on Mac OS X 10.4.11 (8S165).

There are most likely two issues here:

1. Evangelism to fix the site to play nice with Safari/WebKit.
2. Improve Safari's infinite redirection detection.

Comment 2 David Kilzer (:ddkilzer) 2007-12-03 09:56:17 PST
<rdar://problem/5625859>
Comment 3 David Kilzer (:ddkilzer) 2007-12-03 09:58:53 PST
(In reply to comment #2)
> <rdar://problem/5625859>

This radar is for improving the infinite redirection detection.

It would be nice to determine what's going on with the site that makes it redirect like this (if possible), then evangelize the site if necessary.
Comment 4 Sam Stigler 2007-12-17 10:17:16 PST
Unable tp reproduce in r28767, but the issue did occur when I tried again in r28811.
Comment 5 Fabian Mailinator 2008-06-30 11:21:42 PDT
URL now 404s
Comment 6 Sam Stigler 2008-06-30 13:14:48 PDT
I just tried the URL on build 34824 with 10.5.3; it doesn't 404.  It actually loads the page fine, with no redirects.  I suggest this bug be marked as resolved.
Comment 7 Alexey Proskuryakov 2008-07-01 02:53:52 PDT
Since we never made a reduction, closing.