Bug 162386 - Skip stress/string-joining-long-strings-should-not-crash.js on memory limited devices
Summary: Skip stress/string-joining-long-strings-should-not-crash.js on memory limited...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Csaba Osztrogonác
URL:
Keywords:
: 162508 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-09-22 06:19 PDT by Csaba Osztrogonác
Modified: 2016-09-26 07:29 PDT (History)
5 users (show)

See Also:


Attachments
Patch (1.15 KB, patch)
2016-09-22 06:42 PDT, Csaba Osztrogonác
no flags Details | Formatted Diff | Diff
Patch for landing (1.16 KB, patch)
2016-09-26 06:55 PDT, Csaba Osztrogonác
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2016-09-22 06:19:11 PDT
stress/string-joining-long-strings-should-not-crash.js consumes
at least 935Mb memory and then crashes on our JSCOnly bots.
Let's skip it on memory limited devices.
Comment 1 Csaba Osztrogonác 2016-09-22 06:42:32 PDT
Created attachment 289555 [details]
Patch
Comment 2 Csaba Osztrogonác 2016-09-22 06:47:07 PDT
Comment on attachment 289555 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=289555&action=review

> JSTests/stress/string-joining-long-strings-should-not-crash.js:2
> -//@ runDefault
> +//@largeHeap
> +// @runDefault if !$memoryLimited

We need this hack, because run-jsc-stress-tests processes all lines started with "//@".
Comment 3 Csaba Osztrogonác 2016-09-23 07:26:17 PDT
(In reply to comment #0)
> stress/string-joining-long-strings-should-not-crash.js consumes
> at least 935Mb memory and then crashes on our JSCOnly bots.
> Let's skip it on memory limited devices.

note: This test consumes 4.3Gb memory on X86_64
Comment 4 Mark Lam 2016-09-23 11:39:05 PDT
Comment on attachment 289555 [details]
Patch

r=me
Comment 5 WebKit Commit Bot 2016-09-23 12:02:34 PDT
Comment on attachment 289555 [details]
Patch

Clearing flags on attachment: 289555

Committed r206317: <http://trac.webkit.org/changeset/206317>
Comment 6 WebKit Commit Bot 2016-09-23 12:02:36 PDT
All reviewed patches have been landed.  Closing bug.
Comment 7 Ryan Haddad 2016-09-23 14:03:59 PDT
Reverted r206317 for reason:

This change caused timeouts on El Capitan Release JSC tests

Committed r206330: <http://trac.webkit.org/changeset/206330>
Comment 8 Ryan Haddad 2016-09-23 14:04:51 PDT
*** Bug 162508 has been marked as a duplicate of this bug. ***
Comment 9 Csaba Osztrogonác 2016-09-26 06:49:51 PDT
(In reply to comment #7)
> Reverted r206317 for reason:
> 
> This change caused timeouts on El Capitan Release JSC tests
> 
> Committed r206330: <http://trac.webkit.org/changeset/206330>

Sorry for the trouble. It was a typo in my patch, I'll land the fixed patch.
Comment 10 Csaba Osztrogonác 2016-09-26 06:55:56 PDT
Created attachment 289825 [details]
Patch for landing
Comment 11 WebKit Commit Bot 2016-09-26 07:29:14 PDT
Comment on attachment 289825 [details]
Patch for landing

Clearing flags on attachment: 289825

Committed r206374: <http://trac.webkit.org/changeset/206374>
Comment 12 WebKit Commit Bot 2016-09-26 07:29:19 PDT
All reviewed patches have been landed.  Closing bug.