Bug 162348 - New DocumentLoader logging causes crashes
Summary: New DocumentLoader logging causes crashes
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Keith Rollin
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2016-09-21 10:29 PDT by Keith Rollin
Modified: 2016-09-21 11:43 PDT (History)
3 users (show)

See Also:


Attachments
Patch (2.20 KB, patch)
2016-09-21 11:37 PDT, Keith Rollin
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Keith Rollin 2016-09-21 10:29:41 PDT
<rdar://problem/28404744>

Application Specific Information:
CRASHING TEST: contentfiltering/block-after-will-send-request-then-allow-unblock.html

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   com.apple.WebCore  0x0000000110340967 WebCore::DocumentLoader::startLoadingMainResource() + 1159
1   com.apple.WebCore  0x00000001108fd0b0 WebCore::FrameLoader::continueLoadAfterNavigationPolicy(...) + 1312
...

Likely due to accessing m_frame without checking to see if it's nullptr. For instance, this seems particularly ill-advised:

    if (!m_frame || m_request.isNull()) {
        RELEASE_LOG_IF_ALLOWED("startLoadingMainResource: Load canceled after willSendRequest (frame = %p, main = %d)", m_frame, m_frame->isMainFrame());
        return;
    }

If this is the case, this is a regression caused by Bug 162237.
Comment 1 Keith Rollin 2016-09-21 11:37:42 PDT
Created attachment 289470 [details]
Patch
Comment 2 Chris Dumez 2016-09-21 11:43:22 PDT
Comment on attachment 289470 [details]
Patch

Clearing flags on attachment: 289470

Committed r206224: <http://trac.webkit.org/changeset/206224>
Comment 3 Chris Dumez 2016-09-21 11:43:25 PDT
All reviewed patches have been landed.  Closing bug.