Bug 16194 - Double Google search form on www.telegraph.co.uk
Summary: Double Google search form on www.telegraph.co.uk
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Evangelism (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.telegraph.co.uk/news/main....
Keywords: GoogleBug, InRadar
Depends on:
Blocks:
 
Reported: 2007-11-29 15:01 PST by David Kilzer (:ddkilzer)
Modified: 2008-07-17 04:59 PDT (History)
2 users (show)

See Also:


Attachments
Screenshot (23.28 KB, image/png)
2007-11-29 15:02 PST, David Kilzer (:ddkilzer)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Kilzer (:ddkilzer) 2007-11-29 15:01:53 PST
* SUMMARY
The Google search box on www.telegraph.co.uk appears to be drawn twice when accessed via Safari 2.0.4 (419.3), Safari 3.0.4 (523.12) and Firefox 2.0.0.10 on Mac OS X 10.4.11 (8S165).

* STEPS TO REPRODUCE
1. Open the URL:  http://www.telegraph.co.uk/news/main.jhtml?xml=/news/2007/11/12/wtree112.xml

* RESULTS
Two Google search forms appear in the upper right-hand corner of the screen.

* REGRESSION
Apparently not a regression as this affects Safari 2 as well as Safari 3.

* NOTES
- The same page accessed with Safari for Windows (version unknown) and Firefox 2.0.0.10 on Windows does not exhibit this behavior.  (Tested second-hand.)
- Setting the user agent to Firefox 2.0.0.2 or Windows MSIE 6.0 has no effect on the behavior.
Comment 1 David Kilzer (:ddkilzer) 2007-11-29 15:02:40 PST
Created attachment 17596 [details]
Screenshot
Comment 2 David Kilzer (:ddkilzer) 2007-11-29 15:04:11 PST
Probably an evangelism bug; need to determine cause first.

Comment 3 David Kilzer (:ddkilzer) 2007-11-29 15:23:27 PST
(In reply to comment #0)
> * NOTES
> - The same page accessed with Safari for Windows (version unknown) and Firefox
> 2.0.0.10 on Windows does not exhibit this behavior.  (Tested second-hand.)

Safari 3.0.4 for Windows was used.

Comment 4 Alexey Proskuryakov 2007-12-03 02:21:54 PST
I cannot reproduce - is this already fixed server-side?
Comment 5 David Kilzer (:ddkilzer) 2007-12-03 04:30:12 PST
(In reply to comment #4)
> I cannot reproduce - is this already fixed server-side?

This still reproduces easily for me with a local debug build of r28320.

I wonder if it's because of some google.com cookies I may have set?

Comment 6 mitz 2007-12-03 08:12:13 PST
(In reply to comment #4)
> I cannot reproduce - is this already fixed server-side?
> 

Trying making the window narrower. The problem is that there are two overlapping copies of the search box (and some JS to copy what you enter in one copy to the other), but only one of them wraps when the window is made narrow.
Comment 7 BARTdG 2007-12-11 15:15:02 PST
(In reply to comment #6)
> The problem is that there are two
> overlapping copies of the search box (and some JS to copy what you enter in one
> copy to the other), but only one of them wraps when the window is made narrow.

Tested it in Camino and IE7.

IE7 doesn't display the form (or some elements) twice after resizing the window. This is because the web page is rendered in Quirks mode. IE then uses the wrong box model.

Webkit, Safari and Camino use the w3c box model and are right to wrap the form elements.
Comment 8 David Kilzer (:ddkilzer) 2007-12-11 16:01:14 PST
(In reply to comment #7)
> Tested it in Camino and IE7.
> 
> IE7 doesn't display the form (or some elements) twice after resizing the
> window. This is because the web page is rendered in Quirks mode. IE then uses
> the wrong box model.
> 
> Webkit, Safari and Camino use the w3c box model and are right to wrap the form
> elements.

Sounds like an evangelism issue to me.  Marking as such.

Comment 9 David Kilzer (:ddkilzer) 2008-02-03 06:26:31 PST
<rdar://problem/5721954>
Comment 10 Robert Blaut 2008-07-17 03:14:56 PDT
I cannot reproduce the problem in the latest WebKit r 35203. So probably the issue is already fixed. Any confirmations?
Comment 11 David Kilzer (:ddkilzer) 2008-07-17 04:59:17 PDT
Yes, this appears to be fixed now.  Tested with Safari 3.0.4 on Tiger 10.4.11.