Bug 161774 - REGRESSION: [mac-wk2] LayoutTest inspector/debugger/breakpoint-columns.html is a flaky failure
Summary: REGRESSION: [mac-wk2] LayoutTest inspector/debugger/breakpoint-columns.html i...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Joseph Pecoraro
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2016-09-08 17:07 PDT by Ryan Haddad
Modified: 2017-01-11 21:16 PST (History)
6 users (show)

See Also:


Attachments
[PATCH] Proposed Fix (1.58 KB, patch)
2017-01-11 16:35 PST, Joseph Pecoraro
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2016-09-08 17:07:29 PDT
LayoutTest inspector/debugger/breakpoint-columns.html is a flaky failure

https://build.webkit.org/builders/Apple%20Yosemite%20Debug%20WK2%20(Tests)/builds/14880

https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=inspector%2Fdebugger%2Fbreakpoint-columns.html

--- /Volumes/Data/slave/yosemite-debug-tests-wk2/build/layout-test-results/inspector/debugger/breakpoint-columns-expected.txt
+++ /Volumes/Data/slave/yosemite-debug-tests-wk2/build/layout-test-results/inspector/debugger/breakpoint-columns-actual.txt
@@ -10,6 +10,7 @@
 CONSOLE MESSAGE: line 12: column test 5
 Testing that breakpoints can be set at various line / column combinations.
 
+ERROR: Received a command response without a corresponding callback or promise. [object Object] 
 Hit breakpoint at line: 0, column: 79
 Hit breakpoint at line: 6, column: 21
 Hit breakpoint at line: 15, column: 8
Comment 1 Radar WebKit Bug Importer 2016-09-08 17:08:09 PDT
<rdar://problem/28217256>
Comment 2 Ryan Haddad 2016-09-08 17:10:18 PDT
First failure on the dashboard was ~r204952, but the test has been quite flaky since ~r204896 on 8/24/18
Comment 3 Joseph Pecoraro 2016-09-08 21:50:42 PDT
> +ERROR: Received a command response without a corresponding callback or promise. [object Object] 

Seems concerning. I don't think we've made any changes here (yet), so I wonder if this is actually a regression with `Map`? I know some changes just landed there (both GC storage, and the implementation).
Comment 4 Ryan Haddad 2016-09-09 09:53:41 PDT
Marked test as flaky in http://trac.webkit.org/projects/webkit/changeset/205747
Comment 5 Joseph Pecoraro 2017-01-11 16:29:38 PST
The Flakiness Dashboard shows this test as all green for an entire month:
https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#tests=inspector%2Fdebugger%2Fbreakpoint-columns.html

I suggest unskipping this. Given the bizarness of the error message seen previously, one I've _never_ seen while running tests or the Inspector itself, I think this was a lower level issue that likely got resolved.
Comment 6 Joseph Pecoraro 2017-01-11 16:35:24 PST
Created attachment 298628 [details]
[PATCH] Proposed Fix
Comment 7 Mark Lam 2017-01-11 16:54:52 PST
Comment on attachment 298628 [details]
[PATCH] Proposed Fix

rs=me
Comment 8 WebKit Commit Bot 2017-01-11 21:16:52 PST
Comment on attachment 298628 [details]
[PATCH] Proposed Fix

Clearing flags on attachment: 298628

Committed r210620: <http://trac.webkit.org/changeset/210620>
Comment 9 WebKit Commit Bot 2017-01-11 21:16:56 PST
All reviewed patches have been landed.  Closing bug.