Bug 161765 - Web Inspector: TimelineDataGridNode should refresh when graph column is resized
Summary: Web Inspector: TimelineDataGridNode should refresh when graph column is resized
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Matt Baker
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2016-09-08 15:38 PDT by Matt Baker
Modified: 2016-09-08 16:23 PDT (History)
7 users (show)

See Also:


Attachments
[Patch] Proposed Fix (6.96 KB, patch)
2016-09-08 15:51 PDT, Matt Baker
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Baker 2016-09-08 15:38:32 PDT
Summary:
TimelineDataGridNode should refresh when graph column is resized. Currently graphs only refresh when the entire view tree is being updated due to a window resize or sidebar expand/collapse.

Now that OverviewTimelineView has two columns (the Name column was added when the navigation sidebar was removed), it's possible for the graph column to be resized without the nodes ever being refreshed.

Steps to Reproduce:
1. Record a timeline
2. Show the overview
3. Change width of the graph column using the column resizer between the Name and Graph columns
  => Record bars aren't recombined as the column size changed
Comment 1 Radar WebKit Bug Importer 2016-09-08 15:38:52 PDT
<rdar://problem/28215674>
Comment 2 Matt Baker 2016-09-08 15:51:43 PDT
Created attachment 288344 [details]
[Patch] Proposed Fix
Comment 3 Brian Burg 2016-09-08 16:01:09 PDT
Comment on attachment 288344 [details]
[Patch] Proposed Fix

r=me
Comment 4 WebKit Commit Bot 2016-09-08 16:23:27 PDT
Comment on attachment 288344 [details]
[Patch] Proposed Fix

Clearing flags on attachment: 288344

Committed r205676: <http://trac.webkit.org/changeset/205676>
Comment 5 WebKit Commit Bot 2016-09-08 16:23:31 PDT
All reviewed patches have been landed.  Closing bug.