Bug 161737 - Emoji in GitHub's emoji suggester are mojibake
Summary: Emoji in GitHub's emoji suggester are mojibake
Status: RESOLVED CONFIGURATION CHANGED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Text (show other bugs)
Version: Safari 9
Hardware: Macintosh OS X 10.11
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-08 06:30 PDT by Adam Roben (:aroben)
Modified: 2016-09-16 09:35 PDT (History)
2 users (show)

See Also:


Attachments
incorrect rendering from STP (9.91 KB, image/png)
2016-09-08 06:30 PDT, Adam Roben (:aroben)
no flags Details
correct rendering from Safari 9 (13.06 KB, image/png)
2016-09-08 06:31 PDT, Adam Roben (:aroben)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Roben (:aroben) 2016-09-08 06:30:39 PDT
Created attachment 288263 [details]
incorrect rendering from STP

To reproduce:

1. Sign in to GitHub
2. Go to any GitHub issue or pull request (https://github.com/aroben/test/issues/7 is an example)
3. Type a colon (:) in the "Leave a comment" field to show the emoji suggester

The emoji suggestions that come up are mojibake (garbled text). See screenshot.

This happens in Safari Tech Preview 12. It does not happen in Safari 9.1.3 or Chrome 52.
Comment 1 Adam Roben (:aroben) 2016-09-08 06:31:00 PDT
Created attachment 288264 [details]
correct rendering from Safari 9
Comment 2 Myles C. Maxfield 2016-09-08 15:51:03 PDT
(In reply to comment #0)
> Created attachment 288263 [details]
> incorrect rendering from STP
> 
> To reproduce:
> 
> 1. Sign in to GitHub
> 2. Go to any GitHub issue or pull request
> (https://github.com/aroben/test/issues/7 is an example)
> 3. Type a colon (:) in the "Leave a comment" field to show the emoji
> suggester
> 
> The emoji suggestions that come up are mojibake (garbled text). See
> screenshot.
> 
> This happens in Safari Tech Preview 12. It does not happen in Safari 9.1.3
> or Chrome 52.

Which OS are you using? On Sierra this works correctly for me.
Comment 3 Adam Roben (:aroben) 2016-09-12 07:27:07 PDT
(In reply to comment #2)
> Which OS are you using? On Sierra this works correctly for me.

OS X 10.11.6
Comment 4 Myles C. Maxfield 2016-09-12 10:28:49 PDT
I can reproduce this with STP but can't reproduce this in a nightly.
Comment 5 Alexey Proskuryakov 2016-09-12 12:30:43 PDT
Perhaps depends on user preferences?
Comment 6 Adam Roben (:aroben) 2016-09-16 08:13:58 PDT
This seems to be fixed in STP 13.
Comment 7 Alexey Proskuryakov 2016-09-16 09:35:43 PDT
Even stranger.