Bug 16161 - REGRESSION: window.moveBy(0, 0) moves the window by -22px vertically
Summary: REGRESSION: window.moveBy(0, 0) moves the window by -22px vertically
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore JavaScript (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords: Regression
Depends on:
Blocks:
 
Reported: 2007-11-27 11:23 PST by Timothy Hatcher
Modified: 2007-11-27 15:20 PST (History)
0 users

See Also:


Attachments
Test case (187 bytes, text/html)
2007-11-27 11:23 PST, Timothy Hatcher
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timothy Hatcher 2007-11-27 11:23:24 PST
Calling window.moveBy(0, 0) moves the window up 22px. This seems to be the height of the window title. Calling window.moveBy(0, -22) does not move the window.

See attached test case.
Comment 1 Timothy Hatcher 2007-11-27 11:23:47 PST
Created attachment 17559 [details]
Test case
Comment 2 Timothy Hatcher 2007-11-27 15:06:29 PST
Landed in r28083. http://trac.webkit.org/projects/webkit/changeset/28083
Comment 3 Timothy Hatcher 2007-11-27 15:20:25 PST
This was a regression. It worked in Safari 3 on Leopard.