Bug 161411 - REGRESSION (r205094?): LayoutTests editing/mac/spelling/accept-misspelled-candidate.html and editing/mac/spelling/autocorrection-contraction.html are flaky
Summary: REGRESSION (r205094?): LayoutTests editing/mac/spelling/accept-misspelled-can...
Status: RESOLVED DUPLICATE of bug 161366
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-30 16:06 PDT by Ryan Haddad
Modified: 2016-09-06 10:35 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2016-08-30 16:06:48 PDT
REGRESSION: LayoutTests editing/mac/spelling/accept-misspelled-candidate.html and editing/mac/spelling/autocorrection-contraction.html are flaky

https://build.webkit.org/results/Apple%20El%20Capitan%20Debug%20WK2%20(Tests)/r205197%20(7856)/results.html

https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=editing%2Fmac%2Fspelling%2Faccept-misspelled-candidate.html
https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=editing%2Fmac%2Fspelling%2Fautocorrection-contraction.html

--- /Volumes/Data/slave/elcapitan-debug-tests-wk2/build/layout-test-results/editing/mac/spelling/accept-misspelled-candidate-expected.txt
+++ /Volumes/Data/slave/elcapitan-debug-tests-wk2/build/layout-test-results/editing/mac/spelling/accept-misspelled-candidate-actual.txt
@@ -17,6 +17,16 @@
 EDITING DELEGATE: shouldChangeSelectedDOMRange:range from 4 of #text > DIV > BODY > HTML > #document to 4 of #text > DIV > BODY > HTML > #document toDOMRange:range from 5 of #text > DIV > BODY > HTML > #document to 5 of #text > DIV > BODY > HTML > #document affinity:NSSelectionAffinityDownstream stillSelecting:FALSE
 EDITING DELEGATE: webViewDidChangeSelection:WebViewDidChangeSelectionNotification
 EDITING DELEGATE: webViewDidChange:WebViewDidChangeNotification
+EDITING DELEGATE: shouldChangeSelectedDOMRange:range from 5 of #text > DIV > BODY > HTML > #document to 5 of #text > DIV > BODY > HTML > #document toDOMRange:range from 2 of #text > DIV > BODY > HTML > #document to 3 of #text > DIV > BODY > HTML > #document affinity:NSSelectionAffinityDownstream stillSelecting:FALSE
+EDITING DELEGATE: shouldInsertText:’ replacingDOMRange:range from 2 of #text > DIV > BODY > HTML > #document to 3 of #text > DIV > BODY > HTML > #document givenAction:WebViewInsertActionTyped
+EDITING DELEGATE: shouldChangeSelectedDOMRange:range from 5 of #text > DIV > BODY > HTML > #document to 5 of #text > DIV > BODY > HTML > #document toDOMRange:range from 2 of #text > DIV > BODY > HTML > #document to 3 of #text > DIV > BODY > HTML > #document affinity:NSSelectionAffinityDownstream stillSelecting:FALSE
+EDITING DELEGATE: shouldChangeSelectedDOMRange:range from 5 of #text > DIV > BODY > HTML > #document to 5 of #text > DIV > BODY > HTML > #document toDOMRange:range from 2 of #text > DIV > BODY > HTML > #document to 3 of #text > DIV > BODY > HTML > #document affinity:NSSelectionAffinityDownstream stillSelecting:FALSE
+EDITING DELEGATE: webViewDidChangeSelection:WebViewDidChangeSelectionNotification
+EDITING DELEGATE: webViewDidChangeSelection:WebViewDidChangeSelectionNotification
+EDITING DELEGATE: shouldChangeSelectedDOMRange:range from 2 of #text > DIV > BODY > HTML > #document to 2 of #text > DIV > BODY > HTML > #document toDOMRange:range from 3 of #text > DIV > BODY > HTML > #document to 3 of #text > DIV > BODY > HTML > #document affinity:NSSelectionAffinityDownstream stillSelecting:FALSE
+EDITING DELEGATE: webViewDidChangeSelection:WebViewDidChangeSelectionNotification
+EDITING DELEGATE: webViewDidChange:WebViewDidChangeNotification
+EDITING DELEGATE: webViewDidChangeSelection:WebViewDidChangeSelectionNotification
 EDITING DELEGATE: webViewDidChangeSelection:WebViewDidChangeSelectionNotification
 EDITING DELEGATE: shouldChangeSelectedDOMRange:range from 4 of #text > DIV > BODY > HTML > #document to 4 of #text > DIV > BODY > HTML > #document toDOMRange:range from 6 of #text > DIV > BODY > HTML > #document to 6 of #text > DIV > BODY > HTML > #document affinity:NSSelectionAffinityDownstream stillSelecting:FALSE
 EDITING DELEGATE: webViewDidChangeSelection:WebViewDidChangeSelectionNotification
@@ -42,4 +52,4 @@
 TEST COMPLETE
 This test verifies that accepted candidates are not autocorrected. You should see phrase "it's a mesage." The bug occurs if "mesage" was corrected to "message."
 
-it's a mesage  
+it’s a mesage
Comment 1 Ryan Haddad 2016-08-30 16:08:48 PDT
These two tests failed once on Yosemite Debug WK2 with https://trac.webkit.org/changeset/205096 (which seems unrelated), but they have continued to be flaky on El Capitan Debug WK2 since https://trac.webkit.org/changeset/205104
Comment 2 Alexey Proskuryakov 2016-08-31 16:30:03 PDT
This looks bad. Should we roll out r205104?
Comment 3 Chris Dumez 2016-08-31 16:47:56 PDT
It seems unlikely r205104 would cause flakiness, it could cause crashes but I don't see how it could introduce flaky TEXT diffs.
Comment 4 Ryan Haddad 2016-09-02 17:06:41 PDT
Marked tests as flaky in http://trac.webkit.org/projects/webkit/changeset/205385
Comment 5 Alexey Proskuryakov 2016-09-06 10:03:35 PDT
-it's a mesage  
+it’s a mesage

This failure looks very much like the one in bug 161366 - automatic text replacement taking place whereas it hasn't before.
Comment 6 Jonathan Bedard 2016-09-06 10:35:20 PDT
This is definitely a duplicate of bug 161366.  Was able to reproduce by running editing/inserting/smart-link-when-caret-is-moved-before-URL.html.  I am looking at the fix for this right now.
Comment 7 Jonathan Bedard 2016-09-06 10:35:45 PDT

*** This bug has been marked as a duplicate of bug 161366 ***