Bug 16132 - Text hidden by "color: transparent;" CSS rule on www.sancarlosll.org (MS FrontPage 6.0)
Summary: Text hidden by "color: transparent;" CSS rule on www.sancarlosll.org (MS Fron...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Evangelism (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.sancarlosll.org/Archive/tr...
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-25 12:35 PST by Gavin Sherlock
Modified: 2008-07-18 01:03 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gavin Sherlock 2007-11-25 12:35:34 PST
Go to URL - majority of page doesn't show up.  Works fine in Firefox (2.0.0.9).  Inspector Console doesn't indicate any errors.  Also, the related urls:

http://www.sancarlosll.org/Player%20Levels.htm
http://www.sancarlosll.org/Archive/league_&_player_levels.htm

have the same problem, and also work in Firefox.  Tested in r28007 on 10.4.11.  Note, the page also does not work in either release Safari 3.0.4 (523.12), or 2.0.4 (419.3) under Tiger (10.4.11 and 10.4.10 respectively), so is not a regression.  I haven't tested on Leopard.
Comment 1 David Kilzer (:ddkilzer) 2007-11-25 14:06:50 PST
Confirmed with a local debug build of WebKit r28012 with Safari 3.0.4 (523.12) on Mac OS X 10.4.11 (8S165).

The problem is in the <http://www.sancarlosll.org/_themes/quad/quad1011.css> stylesheet which contains the following rule:

TABLE{
table-border-color-light:#CCCC99;
table-border-color-dark:#666666;
border-color:#666666;
color:transparent;
}

The "color:transparent;" rule is inherited by the text within the tables, which causes it to disappear.

I suspect this is an evangelism issue, but I'm not sure.
Comment 2 David Kilzer (:ddkilzer) 2007-11-25 14:15:59 PST
(In reply to comment #1)
> The "color:transparent;" rule is inherited by the text within the tables, which
> causes it to disappear.

When inspecting the page, I noticed an unprintable character appeared after "color: transparent;" rule.  Filed Bug 16134.

Comment 3 Dave Hyatt 2007-11-25 15:09:02 PST
This is an evangelism issue yes.  transparent is a valid color keyword in CSS3.

Comment 4 Gavin Sherlock 2007-11-25 15:16:10 PST
Have emailed web master suggesting rule be modified or deleted.
Comment 5 Robert Blaut 2008-02-11 01:57:46 PST
I checked the page with Webkit r30123 and found they modified its CSS file. The page works almost the same as in Firefox except border of a table is not visible. 
Comment 6 Oliver Hunt 2008-07-18 01:03:36 PDT
Page appears to work now.