Bug 161126 - menclose is not displayed correctly when zooming in / out
Summary: menclose is not displayed correctly when zooming in / out
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: MathML (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on: 160077 161127
Blocks: 170229
  Show dependency treegraph
 
Reported: 2016-08-23 23:34 PDT by Frédéric Wang (:fredw)
Modified: 2017-12-20 09:17 PST (History)
1 user (show)

See Also:


Attachments
Testcase (579 bytes, text/html)
2016-08-23 23:34 PDT, Frédéric Wang (:fredw)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frédéric Wang (:fredw) 2016-08-23 23:34:11 PDT
Created attachment 286836 [details]
Testcase

The attached testcase was provided by Jacques Distler (from https://golem.ph.utexas.edu/wiki/instiki/show/Sandbox).

When you zoom in / out, the slash and 'D' elements are no longer displayed correctly. This is probably because we store two members m_ascent & m_contentRect on the renderer class and thy are not updated when zooming in / out. In general, in the past the solution for this kind of problem has been to get rid of these members. That's at least easy for m_ascent.
Comment 1 Frédéric Wang (:fredw) 2017-11-29 14:14:34 PST
@Jacques: Do you still have the issue? I can't reproduce it with the testcase on WebKitBuild nightly or epiphany release.
Comment 2 Jacques Distler 2017-11-29 18:50:52 PST
Seems to work fine now (Safari 11.0.1 (12604.3.5.1.1), MacOSX).

And it does not seem to be an issue in iOS 11.1.2 either.
Comment 3 Frédéric Wang (:fredw) 2017-11-30 00:08:40 PST
Thanks. I'm not sure what resolved this. Maybe bug 161127 helped but it was probably not enough. Also, there was bug 160077 where I worked on that Dirac equation too but I don't remember exactly. Let's marked it as fixed.