Bug 161063 - Sample Process on notifyDone timed out
Summary: Sample Process on notifyDone timed out
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-22 16:20 PDT by Jonathan Bedard
Modified: 2016-08-29 09:25 PDT (History)
5 users (show)

See Also:


Attachments
Patch (2.90 KB, patch)
2016-08-22 16:24 PDT, Jonathan Bedard
no flags Details | Formatted Diff | Diff
Patch (2.90 KB, patch)
2016-08-22 17:17 PDT, Jonathan Bedard
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Bedard 2016-08-22 16:20:18 PDT
As with other forms of timeouts, sample or spindump should be called to determine the cause of the timeout.
Comment 1 Jonathan Bedard 2016-08-22 16:24:36 PDT
Created attachment 286636 [details]
Patch
Comment 2 Jonathan Bedard 2016-08-22 16:30:53 PDT
A few notes about this patch: There are a number of techniques used in this patch that do not seem to adhere to the architecture of WebKit.  This particular code path is classified as a timeout, but the location and logging of this type of error is consistent with a text difference rather than a timeout or a crash.  Because of this, the mechanisms used in the TestController are unavailable to this class, hence the hard-coding of the process name.  It is possible to entirely define TestController::webProcessName() in the TestController header, which allows the InjectedBundle library to access this function, but such a change seemed to violate the intent and future plans for the function.
Comment 3 Alexey Proskuryakov 2016-08-22 16:54:09 PDT
Comment on attachment 286636 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=286636&action=review

> Tools/WebKitTestRunner/InjectedBundle/TestRunner.cpp:163
> +    snprintf(buffer, sizeof(buffer), "#PID UNRESPONSIVE - %s (pid %d)\n", "com.apple.WebKit.WebContent.Development", getpid());

The current process name can be taken from getprogname(), although that's not portable.
Comment 4 Jonathan Bedard 2016-08-22 17:04:32 PDT
(In reply to comment #3)
> Comment on attachment 286636 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=286636&action=review
> 
> > Tools/WebKitTestRunner/InjectedBundle/TestRunner.cpp:163
> > +    snprintf(buffer, sizeof(buffer), "#PID UNRESPONSIVE - %s (pid %d)\n", "com.apple.WebKit.WebContent.Development", getpid());
> 
> The current process name can be taken from getprogname(), although that's
> not portable.

Well, neither are sample and spindump, all of the code for this has been port specific so far anyways.
Comment 5 Jonathan Bedard 2016-08-22 17:17:41 PDT
Created attachment 286642 [details]
Patch
Comment 6 WebKit Commit Bot 2016-08-29 09:25:38 PDT
Comment on attachment 286642 [details]
Patch

Clearing flags on attachment: 286642

Committed r205123: <http://trac.webkit.org/changeset/205123>
Comment 7 WebKit Commit Bot 2016-08-29 09:25:47 PDT
All reviewed patches have been landed.  Closing bug.