RESOLVED FIXED 160991
Rename LifecycleCallback to CustomElementReaction
https://bugs.webkit.org/show_bug.cgi?id=160991
Summary Rename LifecycleCallback to CustomElementReaction
Ryosuke Niwa
Reported 2016-08-18 20:42:56 PDT
Rename LifecycleCallbackQueue and CustomElementLifecycleProcessingStack to CustomElementReactionQueue and CustomElementReactionStack per the latest spec: https://html.spec.whatwg.org/#custom-element-reactions
Attachments
Renamed classes (48.43 KB, patch)
2016-08-18 20:50 PDT, Ryosuke Niwa
no flags
Fixed CMake builds (48.43 KB, patch)
2016-08-18 21:01 PDT, Ryosuke Niwa
cdumez: review+
Ryosuke Niwa
Comment 1 2016-08-18 20:50:24 PDT
Created attachment 286434 [details] Renamed classes
Ryosuke Niwa
Comment 2 2016-08-18 21:01:22 PDT
Created attachment 286436 [details] Fixed CMake builds
Ryosuke Niwa
Comment 3 2016-08-18 21:02:20 PDT
It’s kind of annoying that we have CustomElement*s*Registry and then CustomElementReactionQueue but I guess that matches the spec. I hate plural/singular difference in English so much :(
Chris Dumez
Comment 4 2016-08-19 09:21:44 PDT
Comment on attachment 286436 [details] Fixed CMake builds View in context: https://bugs.webkit.org/attachment.cgi?id=286436&action=review r=me > Source/WebCore/bindings/js/JSCustomElementsRegistryCustom.cpp:42 > +static JSObject* getCallback(ExecState& state, JSObject& prototype, const Identifier& id) maybe getCustomElementCallback() ? I don't feel strongly, land either way. > Source/WebCore/dom/CustomElementReactionQueue.cpp:43 > +class CustomElementReactionQueueItem { In a follow up, it could be nice to move this class under CustomElementReactionQueue and rename it to "Item".
Ryosuke Niwa
Comment 5 2016-08-19 13:59:29 PDT
Comment on attachment 286436 [details] Fixed CMake builds View in context: https://bugs.webkit.org/attachment.cgi?id=286436&action=review >> Source/WebCore/bindings/js/JSCustomElementsRegistryCustom.cpp:42 >> +static JSObject* getCallback(ExecState& state, JSObject& prototype, const Identifier& id) > > maybe getCustomElementCallback() ? I don't feel strongly, land either way. Sure, I was initially using that name and I thought it was too long. Fixed. >> Source/WebCore/dom/CustomElementReactionQueue.cpp:43 >> +class CustomElementReactionQueueItem { > > In a follow up, it could be nice to move this class under CustomElementReactionQueue and rename it to "Item". I don’t want to do that because then I have to pull in a whole bunch of headers in CustomElementReactionQueue.h
Ryosuke Niwa
Comment 6 2016-08-19 14:04:10 PDT
Ryan Haddad
Comment 7 2016-08-19 15:06:04 PDT
Note You need to log in before you can comment on or make changes to this bug.