Bug 160858 - Rename SocketStreamHandleBase to SocketStreamHandle and SocketStreamHandle to SocketStreamHandleImpl
Summary: Rename SocketStreamHandleBase to SocketStreamHandle and SocketStreamHandle to...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Alex Christensen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-15 12:46 PDT by Alex Christensen
Modified: 2016-08-16 10:45 PDT (History)
2 users (show)

See Also:


Attachments
Patch (185.52 KB, patch)
2016-08-15 12:49 PDT, Alex Christensen
no flags Details | Formatted Diff | Diff
Patch (188.07 KB, patch)
2016-08-15 13:00 PDT, Alex Christensen
no flags Details | Formatted Diff | Diff
Patch (188.22 KB, patch)
2016-08-15 13:15 PDT, Alex Christensen
no flags Details | Formatted Diff | Diff
Patch (188.58 KB, patch)
2016-08-15 13:27 PDT, Alex Christensen
no flags Details | Formatted Diff | Diff
Patch (189.60 KB, patch)
2016-08-15 13:36 PDT, Alex Christensen
beidson: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Christensen 2016-08-15 12:46:34 PDT
Rename SocketStreamHandleBase to SocketStreamHandle and SocketStreamHandle to SocketStreamHandleImpl
Comment 1 Alex Christensen 2016-08-15 12:49:46 PDT
Created attachment 286078 [details]
Patch
Comment 2 WebKit Commit Bot 2016-08-15 12:51:51 PDT
Attachment 286078 [details] did not pass style-queue:


ERROR: Source/WebCore/platform/network/cf/SocketStreamHandleImpl.h:64:  The parameter name "error" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebCore/platform/network/cf/SocketStreamHandleImpl.h:101:  One space before end of line comments  [whitespace/comments] [5]
ERROR: Source/WebCore/platform/network/SocketStreamHandle.cpp:38:  Omit int when using unsigned  [runtime/unsigned] [1]
ERROR: Source/WebCore/platform/network/SocketStreamHandle.cpp:124:  One space before end of line comments  [whitespace/comments] [5]
ERROR: Source/WebCore/platform/network/soup/SocketStreamHandleImpl.h:81:  One space before end of line comments  [whitespace/comments] [5]
ERROR: Source/WebCore/platform/network/soup/SocketStreamHandleImplSoup.cpp:37:  Alphabetical sorting problem.  [build/include_order] [4]
ERROR: Source/WebCore/platform/network/SocketStreamHandle.h:68:  One space before end of line comments  [whitespace/comments] [5]
ERROR: Source/WebCore/platform/network/cf/SocketStreamHandleImplCFNet.cpp:54:  "CFNetwork/CFNetwork.h" already included at Source/WebCore/platform/network/cf/SocketStreamHandleImplCFNet.cpp:49  [build/include] [4]
ERROR: Source/WebCore/platform/network/cf/SocketStreamHandleImplCFNet.cpp:148:  Extra space before ( in function call  [whitespace/parens] [4]
ERROR: Source/WebCore/platform/network/cf/SocketStreamHandleImplCFNet.cpp:169:  More than one command on the same line  [whitespace/newline] [4]
ERROR: Source/WebCore/platform/network/cf/SocketStreamHandleImplCFNet.cpp:173:  Should be indented on a separate line, with the colon or comma first on that line.  [whitespace/indent] [4]
ERROR: Source/WebCore/platform/network/cf/SocketStreamHandleImplCFNet.cpp:487:  Missing space before ( in switch(  [whitespace/parens] [5]
ERROR: Source/WebCore/platform/network/cf/SocketStreamHandleImplCFNet.cpp:559:  Missing space before ( in switch(  [whitespace/parens] [5]
ERROR: Source/WebCore/platform/network/cf/SocketStreamHandleImplCFNet.cpp:700:  One space before end of line comments  [whitespace/comments] [5]
Total errors found: 14 in 19 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Alex Christensen 2016-08-15 13:00:35 PDT
Created attachment 286079 [details]
Patch
Comment 4 Alex Christensen 2016-08-15 13:15:08 PDT
Created attachment 286082 [details]
Patch
Comment 5 Alex Christensen 2016-08-15 13:27:25 PDT
Created attachment 286085 [details]
Patch
Comment 6 Alex Christensen 2016-08-15 13:36:29 PDT
Created attachment 286088 [details]
Patch
Comment 7 Brady Eidson 2016-08-15 14:20:06 PDT
Comment on attachment 286088 [details]
Patch

Rubber-stamp based on it being a pure rename that we discussed in person.
Comment 8 Alex Christensen 2016-08-15 14:25:18 PDT
https://trac.webkit.org/changeset/204483
Comment 9 Alexey Proskuryakov 2016-08-15 22:59:48 PDT
Impl is an abbr :(
Comment 10 Alex Christensen 2016-08-16 10:45:41 PDT
We have BlobRegistry, BlobRegistryProxy, and BlobRegistryImpl.  We will soon have SocketStreamHandle, SocketStreamHandleProxy, and SocketStreamHandleImpl.  If anyone suggests a better naming scheme, I will use it.