Bug 160771 - [GTK] HTML special symbol © doubled in render output after refresh
Summary: [GTK] HTML special symbol © doubled in render output after refresh
Status: NEW
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Nightly Build
Hardware: PC Linux
: P3 Normal
Assignee: Nobody
Depends on:
Reported: 2016-08-11 11:24 PDT by Marcel Tiede
Modified: 2016-08-15 01:54 PDT (History)
3 users (show)

See Also:

Testcase (356 bytes, application/octet-stream)
2016-08-11 11:24 PDT, Marcel Tiede
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel Tiede 2016-08-11 11:24:20 PDT
Created attachment 285838 [details]

If I'm loading the attached PHP-File in a minimal appplication using the latest webkitgtk (2.12.3) the "(c)" Symbol is doubled after a refresh. The symbol "©" is always sent once by the server.

In the dom view the "©" is shown twice, but if i check the source code via the browser it's shown only once.
Comment 1 Marcel Tiede 2016-08-11 11:36:49 PDT
The same is happening with " ": It gets doubled after a refresh.
Comment 2 Carlos Alberto Lopez Perez 2016-08-11 12:04:32 PDT
I tried loading your testcase on a standard apache webserver but I got this error:

PHP Parse error:  syntax error, unexpected 'version' (T_STRING) in xhtmlent.php on line 3, referer: https://people.igalia.com/clopez/wkbug/160771/

I fixed it like this:

$ cat xhtmlent.php 
header('Content-Type: application/xhtml+xml; charset=ISO-8859-1');
echo '<?xml version="1.0" ?>';
echo '<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">';
echo '<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="de" lang="de" dir="ltr"><head><title>test</title></head><body>&copy;</body></html>';

And uploaded it to here: https://people.igalia.com/clopez/wkbug/160771/xhtmlent.php

I tried refreshing several times with epiphany (2.12) and the minibrowser (trunk) and I'm not able to reproduce the issue. I only see a (c) symbol.

Are you able to reproduce it on the page I uploaded ?
Comment 3 Marcel Tiede 2016-08-11 12:20:28 PDT
Yes I can reproduce this behaviour on the webpage https://people.igalia.com/clopez/wkbug/160771/xhtmlent.php with epiphany and my mini application using webkitgtk webview.

I'm using epiphany 3.20.3 from archlinux 64bit version.

User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/602.1 (KHTML, like Gecko) Version/8.0 Safari/602.1 Epiphany/3.20.3
Comment 4 Carlos Alberto Lopez Perez 2016-08-12 11:30:45 PDT
After more testing, I was able to reproduce this on Fedora 24 or Debian testing.

However I can't reproduce it on Debian stable.

I wonder if this is triggered by some different version of some library?
Comment 5 Michael Catanzaro 2016-08-15 01:54:14 PDT
I can also reproduce it.