Bug 15975 - REGRESSION: rcov 0.8 CSS highlighting is broken in Safari 3
Summary: REGRESSION: rcov 0.8 CSS highlighting is broken in Safari 3
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.5
: P1 Normal
Assignee: Nobody
URL: http://taw.chaosforge.org/magic_xml/c...
Keywords: HasReduction, InRadar, Regression
Depends on:
Blocks: 41115
  Show dependency treegraph
 
Reported: 2007-11-13 17:34 PST by Luis de la Rosa
Modified: 2011-02-04 18:23 PST (History)
5 users (show)

See Also:


Attachments
Reduced test case (223 bytes, text/html)
2007-11-13 19:24 PST, Mark Rowe (bdash)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luis de la Rosa 2007-11-13 17:34:11 PST
I reported this originally on http://www.luisdelarosa.com/2007/11/10/ruby-bugs-on-leopard/

rcov is a code coverage tool for ruby.  Its latest version is 0.8.0.2.  The output will highlight covered lines of code in green and uncovered in red.  This worked perfectly in Tiger with Safari 2.  However, in Leopard with Safari 3, it no longer highlights.  I also tested with OmniWeb 5.6 and it does not highlight either.

However, Firefox 2 on Leopard does work properly as does Camino on Leopard.

One good URL that shows the information is http://taw.chaosforge.org/magic_xml/coverage/magic_xml_rb.html

Rcov 0.4 however works properly in Safari 3 on Leopard and here's an example URL:
http://bioruby-doc.org/coverage/-tmp-bioruby-lib-bio-db-gff_rb.html

If you look at the difference, it looks like there are some extra XHTML tags that are of the form "<a name="line1" />" which throw off Safari 3.

Also I tested a WebKit nightly, but I don't remember the version - I will test again soon but it was broken as well.
Comment 1 Mark Rowe (bdash) 2007-11-13 19:24:19 PST
Created attachment 17255 [details]
Reduced test case
Comment 2 Mark Rowe (bdash) 2007-11-13 19:31:17 PST
http://software.hixie.ch/utilities/js/live-dom-viewer/ does a good job of showing the difference here between Firefox and Safari.  For the following snippet:

<span><a/>Span One</span>
<span><a/>Span Two</span>

In Safari, the DOM is equivalent to the DOM given by:
<span><a>Span One</a></span>
<a> <span></span></a><a>Span Two </a>

While in Firefox, the DOM is equivalent to that given by:
<span><a>Span One</a></span>
<span><a>Span Two</a></span>

Comment 3 Mark Rowe (bdash) 2007-11-13 19:31:54 PST
<rdar://problem/5599013>
Comment 4 mitz 2007-11-14 07:55:47 PST
What does libhtml5 say?
Comment 5 Alexey Proskuryakov 2007-11-14 12:34:11 PST
Looks like it agrees with WebKit: <http://james.html5.org/parsetree.html>. MSIE builds a very different tree however.
Comment 6 Alexey Proskuryakov 2010-10-20 12:31:05 PDT
This problem still occurs in Safari 5 and nightlies.

Adam, do we want to track this as an HTML5 parser compatibility issue?
Comment 7 Adam Barth 2010-10-20 13:04:56 PDT
> Adam, do we want to track this as an HTML5 parser compatibility issue?

Sure.
Comment 8 Adam Barth 2011-02-04 18:23:05 PST
I'm sorry, but I don't think we're going to fix this site.  The site is now broken in Firefox 4 as well.  It looks like a cool tool though.