Bug 159070 - REGRESSION(r201171): CRASH at WebKit::WebInspectorProxy::open() + 31 when running inspector layout tests
Summary: REGRESSION(r201171): CRASH at WebKit::WebInspectorProxy::open() + 31 when run...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Brian Burg
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2016-06-23 14:17 PDT by Brian Burg
Modified: 2016-06-24 17:37 PDT (History)
7 users (show)

See Also:


Attachments
Proposed Fix (2.48 KB, patch)
2016-06-23 14:24 PDT, Brian Burg
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Burg 2016-06-23 14:17:01 PDT
Looks like something weird is going on.
Comment 1 Brian Burg 2016-06-23 14:17:13 PDT
<rdar://problem/26768628>
Comment 2 Brian Burg 2016-06-23 14:24:36 PDT
Created attachment 281931 [details]
Proposed Fix
Comment 3 Joseph Pecoraro 2016-06-24 17:03:17 PDT
Comment on attachment 281931 [details]
Proposed Fix

View in context: https://bugs.webkit.org/attachment.cgi?id=281931&action=review

r=me

> Source/WebKit2/ChangeLog:12
> +        However, it doesn't make sense that we would hit the null dereference here:

Should we add an ASSERT?
Comment 4 Brian Burg 2016-06-24 17:15:45 PDT
Comment on attachment 281931 [details]
Proposed Fix

View in context: https://bugs.webkit.org/attachment.cgi?id=281931&action=review

>> Source/WebKit2/ChangeLog:12
>> +        However, it doesn't make sense that we would hit the null dereference here:
> 
> Should we add an ASSERT?

I added a more valuable assert in https://bugs.webkit.org/show_bug.cgi?id=159073. Since this code is only ever called via IPC (one frame below bringToFront()) an assertion here is not going to tell us anything useful, as the backtrace will just be full of IPC junk.
Comment 5 WebKit Commit Bot 2016-06-24 17:37:02 PDT
Comment on attachment 281931 [details]
Proposed Fix

Clearing flags on attachment: 281931

Committed r202464: <http://trac.webkit.org/changeset/202464>
Comment 6 WebKit Commit Bot 2016-06-24 17:37:05 PDT
All reviewed patches have been landed.  Closing bug.