Bug 159055 - Match updated spec for `/\w/iu` and `/\W/iu`
Summary: Match updated spec for `/\w/iu` and `/\W/iu`
Status: RESOLVED DUPLICATE of bug 158505
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Yusuke Suzuki
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-23 02:17 PDT by Mathias Bynens
Modified: 2016-06-26 09:42 PDT (History)
9 users (show)

See Also:


Attachments
Patch (10.10 KB, patch)
2016-06-23 04:05 PDT, Yusuke Suzuki
msaboff: review-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mathias Bynens 2016-06-23 02:17:31 PDT
Now that https://github.com/tc39/ecma262/pull/525 has landed, `\u017F` (LATIN SMALL LETTER LONG S) and `\u212A` (KELVIN SIGN) are word characters for `/iu` patterns.

Expected behavior:

    /\w/iu.test('\u017F') // true
    /\w/iu.test('\u212A') // true
    /\W/iu.test('\u017F') // false
    /\W/iu.test('\u212A') // false

Actual behavior: currently, they all result in `true`.
Comment 1 Yusuke Suzuki 2016-06-23 04:05:15 PDT
Created attachment 281906 [details]
Patch
Comment 2 Michael Saboff 2016-06-24 17:15:52 PDT
This work has already been done.  See https://bugs.webkit.org/show_bug.cgi?id=158505

*** This bug has been marked as a duplicate of bug 158505 ***
Comment 3 Yusuke Suzuki 2016-06-26 09:42:36 PDT
(In reply to comment #2)
> This work has already been done.  See
> https://bugs.webkit.org/show_bug.cgi?id=158505
> 
> *** This bug has been marked as a duplicate of bug 158505 ***

Ah, thanks!