Patch forthcoming.
Created attachment 281721 [details] Inline the code
Attachment 281721 [details] did not pass style-queue: ERROR: Source/WebCore/platform/mac/WebVideoFullscreenInterfaceMac.mm:294: Place brace on its own line for function definitions. [whitespace/braces] [4] ERROR: Source/WebCore/platform/mac/WebVideoFullscreenInterfaceMac.mm:342: The parameter name "playbackSessionModel" adds no information, so it should be removed. [readability/parameter_name] [5] Total errors found: 2 in 16 files If any of these errors are false positives, please file a bug against check-webkit-style.
Comment on attachment 281721 [details] Inline the code View in context: https://bugs.webkit.org/attachment.cgi?id=281721&action=review > Source/WebCore/platform/mac/WebVideoFullscreenInterfaceMac.mm:108 > + WebCore::WebVideoFullscreenInterfaceMac* _webVideoFullscreenInterfaceMac; > + > + NSSize _videoDimensions; > + BOOL _playing; > + > + RetainPtr<PIPViewController> _pipViewController; > + RetainPtr<NSViewController> _videoViewContainerController; > + RetainPtr<WebVideoViewContainer> _videoViewContainer; > + PIPState _pipState; > + BOOL _didRequestExitingPIP; > + BOOL _exitingToStandardFullscreen; > + RetainPtr<NSWindow> _returningWindow; > + NSRect _returningRect; Minor nits: I don't t think the blank lines add anything. I would prefer to have the BOOLs grouped at the end of the interface defn.
(In reply to comment #3) > Comment on attachment 281721 [details] > Inline the code > > View in context: > https://bugs.webkit.org/attachment.cgi?id=281721&action=review > > > Source/WebCore/platform/mac/WebVideoFullscreenInterfaceMac.mm:108 > > + WebCore::WebVideoFullscreenInterfaceMac* _webVideoFullscreenInterfaceMac; > > + > > + NSSize _videoDimensions; > > + BOOL _playing; > > + > > + RetainPtr<PIPViewController> _pipViewController; > > + RetainPtr<NSViewController> _videoViewContainerController; > > + RetainPtr<WebVideoViewContainer> _videoViewContainer; > > + PIPState _pipState; > > + BOOL _didRequestExitingPIP; > > + BOOL _exitingToStandardFullscreen; > > + RetainPtr<NSWindow> _returningWindow; > > + NSRect _returningRect; > > Minor nits: I don't t think the blank lines add anything. I would prefer to > have the BOOLs grouped at the end of the interface defn. Done. Committed <http://trac.webkit.org/r202274>.