Bug 158605 - Unable to create nested workers
Summary: Unable to create nested workers
Status: RESOLVED DUPLICATE of bug 22723
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-09 20:51 PDT by Chris Dumez
Modified: 2016-06-09 22:15 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Dumez 2016-06-09 20:51:00 PDT
It is currently impossible to create nested workers in WebKit (I.e. Have a worker create another worker).

This works in Firefox but not Chrome.

Test:
http://w3c-test.org/workers/semantics/multiple-workers/003.html
Comment 1 Brady Eidson 2016-06-09 21:29:19 PDT
You could dupe this to https://bugs.webkit.org/show_bug.cgi?id=22723, reassign that one, and use its history to finish what was started
Comment 2 Chris Dumez 2016-06-09 22:15:22 PDT

*** This bug has been marked as a duplicate of bug 22723 ***