Bug 158397 - [JSC] Rename thisValue => receiver and slotBase => holder
Summary: [JSC] Rename thisValue => receiver and slotBase => holder
Status: NEW
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Yusuke Suzuki
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-05 07:26 PDT by Yusuke Suzuki
Modified: 2016-06-05 07:27 PDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yusuke Suzuki 2016-06-05 07:26:59 PDT
Several code misuse thisValue and slotBase, and it sometimes incurs assertion failure.
Let's avoid `this` name. Instead, use |receiver| at least for property lookup.
This name "receiver" is spec-compilant name.