Bug 15831 - REGRESSION: Text wraps and overlaps within table cell on mercurynews.com
Summary: REGRESSION: Text wraps and overlaps within table cell on mercurynews.com
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL: http://www.mercurynews.com/realestate
Keywords: HasReduction, Regression
Depends on:
Blocks:
 
Reported: 2007-11-04 10:26 PST by David Kilzer (:ddkilzer)
Modified: 2013-07-22 10:21 PDT (History)
3 users (show)

See Also:


Attachments
Screenshot (27.09 KB, image/png)
2007-11-04 10:29 PST, David Kilzer (:ddkilzer)
no flags Details
Reduction (551 bytes, text/html)
2007-11-13 09:03 PST, David Kilzer (:ddkilzer)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Kilzer (:ddkilzer) 2007-11-04 10:26:19 PST
* SUMMARY
Text wraps and overlaps within a table cell on the mercurynews.com web site.  The text does not wrap on Firefox 2.0.0.8 or Opera 9.22.

* STEPS TO REPRODUCE
1. Launch Safari/WebKit.
2. Go to URL:  http://www.mercurynews.com/realestate
3. View links next to "Search" button in "San Jose Real Estate" box.

* RESULTS
The "Advanced Search" and "Search Classifieds" links wrap and overlap.

* REGRESSION
Unknown.  Tested with Safari 3.0.4 (5523.10) on Mac OS X 10.5 (9A581).
Comment 1 David Kilzer (:ddkilzer) 2007-11-04 10:29:20 PST
Created attachment 17033 [details]
Screenshot
Comment 2 David Kilzer (:ddkilzer) 2007-11-05 08:48:25 PST
Happens on a local debug build of WebKit r27435 with Safari 3 Public Beta v. 3.0.3 (522.12.1) on Mac OS X 10.4.10 (8R218) Tiger as well.

Comment 3 David Kilzer (:ddkilzer) 2007-11-13 09:03:26 PST
Created attachment 17228 [details]
Reduction

Reduced test case from original page.

Both Firefox 2.0.0.9 and Opera 9.24 render the text within the borders on Mac OS X Tiger.
Comment 4 David Kilzer (:ddkilzer) 2007-11-13 09:07:00 PST
This is actually a regression from Safari 2.0.4 (419.3) with original WebKit on Mac OS X Tiger.  It's not clear why, though, since Safari 2 may be ignoring some of the CSS properties or interpreting them differently.  (It looks like it may render bold text differently at the same point size.)

Comment 5 David Kilzer (:ddkilzer) 2007-11-13 09:10:07 PST
This bug also reproduces in the earliest known WebKit Nightly (r11976), so bisect-builds won't provide any more information.

Comment 6 Alexey Proskuryakov 2008-07-28 01:56:45 PDT
This is no longer reproducible on mercurynews.com for me. The reduction still fails, but so it does in Firefox 3.
Comment 7 Robert Hogan 2013-07-22 10:21:51 PDT
WebKit's rendering of this matches IE10, FF22 and Opera Presto. There's no bug here anymore it seems!