Bug 158175 - Youtube Videos stop playing with Safari Tech Preview 5
Summary: Youtube Videos stop playing with Safari Tech Preview 5
Status: NEW
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: Safari Technology Preview
Hardware: Macintosh OS X 10.11
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2016-05-27 19:14 PDT by johnt519
Modified: 2016-06-06 16:07 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description johnt519 2016-05-27 19:14:58 PDT
Using the latest Safari Technology Preview Beta 5, while playing any video on Youtube, the video will, at some point, just stop playing, like the pause button was clicked - which it was not.

You have to click the Play button to get it playing again. This happens with any video, and at a random time during playback. It seems to happen only once during playback of a video. Once restarted, it will play through to the end.

This does not happen with the version of Safari on OS X 10.11.5
Comment 1 Radar WebKit Bug Importer 2016-05-27 22:36:48 PDT
<rdar://problem/26530797>
Comment 2 johnt519 2016-05-30 07:10:20 PDT
Another point of data, it also happens on videos on other sites. For example, this one just did the same thing:

https://realm.io/news/tryswift-maxim-cramer-live-design/
Comment 3 webkit-bugzilla 2016-05-30 11:30:15 PDT
Steps to reproduce:
1) Open a random video like https://www.youtube.com/watch?v=cOBT_-zvUTc
2) Start watching it and try to stop the video after some time e.g. 30 seconds 

What happens:
The video just continue to play.

What you expect:
The video should stop.
Comment 4 webkit-bugzilla 2016-05-30 12:03:50 PDT
Sorry for last comment, shouldn't be here :)

There's a workaround to continue the video if it's stops randomly and won't starts anymore:
1) Do a double right click and click on Show Controls to show the HTML5 video menu
2) Now click on the Play Button from the HTML5 video menu.
Comment 5 s8er01Z 2016-06-01 11:54:34 PDT
Also having this issue...  Tech Preview Beta 5. Seems to happen on all html5 video on various sites.
Comment 6 Ryosuke Niwa 2016-06-06 16:07:28 PDT
This should be fixed on ToT WebKit so the next Safari Tech Preview should have the fix.