Bug 15805 - crash reports seen in isLoadingMultipartContent
Summary: crash reports seen in isLoadingMultipartContent
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 523.x (Safari 3)
Hardware: Mac OS X 10.4
: P2 Normal
Assignee: Darin Adler
URL:
Keywords: InRadar
: 17187 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-11-02 14:50 PDT by Darin Adler
Modified: 2008-02-05 17:56 PST (History)
1 user (show)

See Also:


Attachments
patch (1.25 KB, patch)
2007-11-02 14:53 PDT, Darin Adler
mitz: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Darin Adler 2007-11-02 14:50:50 PDT
Apple's crash tracer has reports of crashes that look like this:

>#0   com.apple.WebCore          0x95417289  WebCore::DocumentLoader::isLoadingMultipartContent() const + 9
  #1   com.apple.WebCore          0x95416eea  WebCore::ImageTokenizer::finish() + 138
  #2   com.apple.WebCore          0x95658b44  WebCore::FrameLoader::endIfNotLoadingMainResource() + 116
  #3   com.apple.WebCore          0x95260053  WebCore::Document::close() + 35
  #4   com.apple.WebCore          0x953134cc  WebCore::JSHTMLDocumentPrototypeFunction::callAsFunction(KJS::ExecState*, KJS::JSObject*, KJS::List const&) + 732

I think it's just a simple missing null check. Lets do a speculative fix.
Comment 1 Darin Adler 2007-11-02 14:53:57 PDT
Created attachment 17001 [details]
patch
Comment 2 mitz 2007-11-02 15:17:01 PDT
Comment on attachment 17001 [details]
patch

r=me, although I'd keep the ASSERT in hope of some day encountering the bug in a debug build and understanding it.
Comment 3 Darin Adler 2007-11-02 16:22:49 PDT
Committed revision 27379.
Comment 4 David Kilzer (:ddkilzer) 2007-11-29 20:44:02 PST
It would appear this isn't fixed.  See Bug 16097.

Comment 5 Darin Adler 2007-12-01 09:43:25 PST
More precisely, it appears there's another crash that now happens in the same circumstance now that the first crash is fixed.
Comment 6 Mark Rowe (bdash) 2008-02-05 17:56:42 PST
*** Bug 17187 has been marked as a duplicate of this bug. ***