Bug 157720 - Can't login on www.safeco.com
Summary: Can't login on www.safeco.com
Status: NEW
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL: http://www.safeco.com
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2016-05-14 21:49 PDT by Ryosuke Niwa
Modified: 2016-05-14 21:56 PDT (History)
5 users (show)

See Also:


Attachments
Screenshot (313.47 KB, image/png)
2016-05-14 21:49 PDT, Ryosuke Niwa
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ryosuke Niwa 2016-05-14 21:49:56 PDT
Created attachment 278959 [details]
Screenshot

Reproduction steps:
1. Click on "Account login"

Expected result:
Login form appears

Actual result:
There is no login form
Comment 1 Radar WebKit Bug Importer 2016-05-14 21:50:28 PDT
<rdar://problem/26288435>
Comment 2 Ryosuke Niwa 2016-05-14 21:53:42 PDT
I'm seeing the following error:

[Error] Multiple 'X-Frame-Options' headers with conflicting values ('ALLOW-FROM http://www.safeco.com, SAMEORIGIN') encountered when loading 'https://customer.safeco.com/accountmanager/Login/loginportlet.aspx'. Falling back to 'DENY'.
[Error] Refused to display 'https://customer.safeco.com/accountmanager/Login/loginportlet.aspx' in a frame because it set 'X-Frame-Options' to 'ALLOW-FROM http://www.safeco.com, SAMEORIGIN'.
Comment 3 Ryosuke Niwa 2016-05-14 21:56:26 PDT
Actually, the bug is also reproducing on Firefox so this might be a bug on the site.

John, do you know what might be going wrong here?