Bug 157705 - ToT WebKit doesn't show tooltip on perf dashboard's summary page
Summary: ToT WebKit doesn't show tooltip on perf dashboard's summary page
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: UI Events (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Ryosuke Niwa
URL:
Keywords: InRadar
Depends on:
Blocks: 148695
  Show dependency treegraph
 
Reported: 2016-05-13 21:30 PDT by Ryosuke Niwa
Modified: 2016-05-14 14:06 PDT (History)
9 users (show)

See Also:


Attachments
Fixes the bug (6.68 KB, patch)
2016-05-13 21:32 PDT, Ryosuke Niwa
no flags Details | Formatted Diff | Diff
Fixed builds (6.68 KB, patch)
2016-05-13 21:33 PDT, Ryosuke Niwa
no flags Details | Formatted Diff | Diff
Fixed one more bug (7.32 KB, patch)
2016-05-13 21:41 PDT, Ryosuke Niwa
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryosuke Niwa 2016-05-13 21:30:30 PDT
Reproduction steps:
1. Install latest safari (or Tech Preview)
2. Open the internal perf dashboard's v3 summary page
3. Hover to one of the bars

Expected result:
Says either "Open charts" or lists the platforms that are missing or ones without baselines.

Actual result:
The title of the ratio bar does not show up.
Comment 1 Ryosuke Niwa 2016-05-13 21:32:51 PDT
Created attachment 278920 [details]
Fixes the bug
Comment 2 Ryosuke Niwa 2016-05-13 21:33:39 PDT
Created attachment 278921 [details]
Fixed builds
Comment 3 Ryosuke Niwa 2016-05-13 21:41:12 PDT
Created attachment 278922 [details]
Fixed one more bug
Comment 4 Ryosuke Niwa 2016-05-13 21:41:34 PDT
<rdar://problem/26130658>
Comment 5 Darin Adler 2016-05-14 08:54:15 PDT
Comment on attachment 278922 [details]
Fixed one more bug

View in context: https://bugs.webkit.org/attachment.cgi?id=278922&action=review

> Source/WebCore/dom/Node.h:282
> +    ContainerNode* parentInComposedTree() const;

What the both callers really need is parentElementInComposedTree. Neither is interested in non-elements. On the other hand it would be tricky to structure the loop right since the starting node is not necessarily an element.
Comment 6 Ryosuke Niwa 2016-05-14 14:04:34 PDT
(In reply to comment #5)
> Comment on attachment 278922 [details]
> Fixed one more bug
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=278922&action=review
> 
> > Source/WebCore/dom/Node.h:282
> > +    ContainerNode* parentInComposedTree() const;
> 
> What the both callers really need is parentElementInComposedTree. Neither is
> interested in non-elements. On the other hand it would be tricky to
> structure the loop right since the starting node is not necessarily an
> element.

Yeah, and we'd need something like parentInComposedTree for the first node anyway.
Comment 7 Ryosuke Niwa 2016-05-14 14:06:35 PDT
Committed r200923: <http://trac.webkit.org/changeset/200923>