Extend protector naming code style guideline to = assignment
https://bugs.webkit.org/show_bug.cgi?id=157591 implemented protector naming rules like so:
But we need to cover operator= assignment, as well.
RefPtr<Node> protector = node;
RefPtr<Node> protectedThis = this;
(In reply to comment #0)
> But we need to cover operator= assignment, as well.
> RefPtr<Node> protector = node;
> RefPtr<Node> protectedThis = this;
There's two ways to cover these cases:
1 - Extend the rule to enforce proper naming in these cases
2 - Extend the rule to disallow these cases and to prefer protector(node)-style initialization, instead.
Since a consensus has been reached on the name of these variables, but no discussion has taken place on disallowing operator= style assignment to these protectors, I'm going to go with #1 and just enforce the name.
If contributors later decide to disallow operator= style, that can be an easy change.
Created attachment 278895 [details]
Comment on attachment 278895 [details]
Clearing flags on attachment: 278895
Committed r200913: <http://trac.webkit.org/changeset/200913>
All reviewed patches have been landed. Closing bug.