Bug 15757 - REGRESSION: spontaneous crash information
Summary: REGRESSION: spontaneous crash information
Status: RESOLVED DUPLICATE of bug 15747
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Critical
Assignee: Nobody
URL:
Keywords: Regression
Depends on:
Blocks:
 
Reported: 2007-10-29 17:09 PDT by Jim Oase
Modified: 2007-10-31 09:59 PDT (History)
0 users

See Also:


Attachments
Crashed while looking up blue screen information for 10.5 (22.05 KB, text/rtf)
2007-10-29 17:11 PDT, Jim Oase
no flags Details
Crash report for Apple (24.01 KB, text/rtf)
2007-10-30 22:17 PDT, Jim Oase
no flags Details
Crash log second crash in 30 seconds (24.01 KB, text/rtf)
2007-10-30 22:27 PDT, Jim Oase
no flags Details
Crash log (23.62 KB, text/rtf)
2007-10-30 22:38 PDT, Jim Oase
no flags Details
crash log ..... ARGH!!! (24.52 KB, text/rtf)
2007-10-30 22:43 PDT, Jim Oase
no flags Details
Crash log crash with build r27306 (23.03 KB, text/rtf)
2007-10-31 07:45 PDT, Jim Oase
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Oase 2007-10-29 17:09:27 PDT
Sorry I lost the previous email concerning this issue

I have another example of the crash.... log
Comment 1 Jim Oase 2007-10-29 17:11:20 PDT
Created attachment 16938 [details]
Crashed while looking up blue screen information for 10.5

Same as before.  Crashed Safari completely
Comment 2 David Kilzer (:ddkilzer) 2007-10-29 21:44:50 PDT
Partial crash log from Attachment #16938 [details]:

Version: r27208 (27208)

PID:    382
Thread: 2

Exception:  EXC_BREAKPOINT (0x0006)
Code[0]:    0x00000002
Code[1]:    0x00000000


Thread 0:
0   libSystem.B.dylib              	0x90009cd7 mach_msg_trap + 7
1   com.apple.CoreFoundation       	0x9082d2b3 CFRunLoopRunSpecific + 2014
2   com.apple.CoreFoundation       	0x9082cace CFRunLoopRunInMode + 61
3   com.apple.HIToolbox            	0x92ded8d8 RunCurrentEventLoopInMode + 285
4   com.apple.HIToolbox            	0x92decfe2 ReceiveNextEventCommon + 385
5   com.apple.HIToolbox            	0x92dece39 BlockUntilNextEventMatchingListInMode + 81
6   com.apple.AppKit               	0x93273465 _DPSNextEvent + 572
7   com.apple.AppKit               	0x93273056 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 137
8   com.apple.Safari               	0x00006cea 0x1000 + 23786
9   com.apple.AppKit               	0x9326cddb -[NSApplication run] + 512
10  com.apple.AppKit               	0x93260d2f NSApplicationMain + 573
11  com.apple.Safari               	0x0005f54a 0x1000 + 386378
12  com.apple.Safari               	0x0005f471 0x1000 + 386161

Thread 1:
0   libSystem.B.dylib              	0x90009cd7 mach_msg_trap + 7
1   com.apple.CoreFoundation       	0x9082d2b3 CFRunLoopRunSpecific + 2014
2   com.apple.CoreFoundation       	0x9082cace CFRunLoopRunInMode + 61
3   com.apple.Foundation           	0x92851bc2 +[NSURLCache _diskCacheSyncLoop:] + 206
4   com.apple.Foundation           	0x927f52e0 forkThreadForFunction + 123
5   libSystem.B.dylib              	0x90024227 _pthread_body + 84

Thread 2 Crashed:
0   libobjc.A.dylib                	0x90a61b09 _objc_error + 86
1   libobjc.A.dylib                	0x90a61b40 __objc_error + 45
2   libobjc.A.dylib                	0x90a601a0 _freedHandler + 53
3   com.apple.WebCore              	0x014418c2 -[WebCoreResourceHandleAsDelegate connection:willCacheResponse:] + 274
4   com.apple.Foundation           	0x9287b713 -[NSURLConnection(NSURLConnectionInternal) _didFinishReturnCachedResponse:] + 615
5   com.apple.Foundation           	0x9293a2a7 -[NSHTTPURLProtocol cachedResponseRevalidated:] + 68
6   com.apple.Foundation           	0x92857272 -[NSConnectionHTTPURLProtocol attemptRetryAfter3xxResponse] + 630
7   com.apple.Foundation           	0x92945047 -[NSConnectionHTTPURLProtocol performHTTPHeaderRead] + 827
8   com.apple.Foundation           	0x92856a44 readStreamCallback2 + 495
9   com.apple.CoreFoundation       	0x9087ab72 _CFStreamSignalEventSynch + 281
10  com.apple.CoreFoundation       	0x9082cf92 CFRunLoopRunSpecific + 1213
11  com.apple.CoreFoundation       	0x9082cace CFRunLoopRunInMode + 61
12  com.apple.Foundation           	0x9282aa0f +[NSURLConnection(NSURLConnectionInternal) _resourceLoadLoop:] + 259
13  com.apple.Foundation           	0x927f52e0 forkThreadForFunction + 123
14  libSystem.B.dylib              	0x90024227 _pthread_body + 84

Comment 3 Jim Oase 2007-10-30 22:17:08 PDT
Created attachment 16959 [details]
Crash report for Apple

The last 3...4 builds have been very slow at time going to the web and then slow getting the data back to display.  The progress bar will stop with the address sitting there.  Then when loading begins the progress bar will move stop for quite awhile and move again.  There have been occasions like this one where the bar stalled twice.  For this attempt the next movement of the bar was followed by the crash.

Jim
Comment 4 Jim Oase 2007-10-30 22:27:12 PDT
Created attachment 16960 [details]
Crash log second crash in 30 seconds

Look at Digg.com article on Leopard icon for Windows users

Jim
Comment 5 Jim Oase 2007-10-30 22:38:17 PDT
Created attachment 16961 [details]
Crash log

Same deal...... Digg.com

Just sitting seems to work.  Scrolling down is when it happens.  I have a wireless Mighty Mouse and I scroll using the ball.

Jim
Comment 6 Jim Oase 2007-10-30 22:43:31 PDT
Created attachment 16962 [details]
crash log ..... ARGH!!!

Go to Digg. com  select the discussion for the story on Leopard's icons for window users.  Then using the scroll ball on the mighty mouse scroll up and down a few times.  The crash will occur while scrolling down

Jim
Comment 7 Brady Eidson 2007-10-30 22:52:27 PDT
Note crash logs 2-5 are the same, but #1 is unrelated
Comment 8 Jim Oase 2007-10-31 07:45:13 PDT
Created attachment 16965 [details]
Crash log crash with build r27306

Hopefully this is the same as the previous 5 crashes.  This is the first time I used new build r27306.

Jim
Comment 9 David Kilzer (:ddkilzer) 2007-10-31 09:18:47 PDT
(In reply to comment #8)
> Hopefully this is the same as the previous 5 crashes.  This is the first time I
> used new build r27306.

It is the same as crashes 2-5.

Version: r27306 (27306)

PID:    514
Thread: 0

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0 Crashed:
0   com.apple.JavaScriptCore       	0x004a5df0 KJS::typeStringForValue(KJS::JSValue*) + 144
1   com.apple.JavaScriptCore       	0x004ae344 KJS::EqualNode::evaluate(KJS::ExecState*) + 20
2   com.apple.JavaScriptCore       	0x004a760d KJS::IfNode::execute(KJS::ExecState*) + 109
3   com.apple.JavaScriptCore       	0x0047730e KJS::SourceElementsNode::execute(KJS::ExecState*) + 46
4   com.apple.JavaScriptCore       	0x00477140 KJS::BlockNode::execute(KJS::ExecState*) + 32
5   com.apple.JavaScriptCore       	0x004a7688 KJS::IfNode::execute(KJS::ExecState*) + 232
6   com.apple.JavaScriptCore       	0x0047730e KJS::SourceElementsNode::execute(KJS::ExecState*) + 46
7   com.apple.JavaScriptCore       	0x004dae81 KJS::FunctionBodyNode::execute(KJS::ExecState*) + 417
8   com.apple.JavaScriptCore       	0x004771ec KJS::FunctionImp::execute(KJS::ExecState*) + 28
9   com.apple.JavaScriptCore       	0x004d996c KJS::FunctionImp::callAsFunction(KJS::ExecState*, KJS::JSObject*, KJS::List const&) + 284
10  com.apple.JavaScriptCore       	0x004b83f4 KJS::FunctionCallResolveNode::evaluate(KJS::ExecState*) + 884
11  com.apple.JavaScriptCore       	0x004a753d KJS::ExprStatementNode::execute(KJS::ExecState*) + 109
12  com.apple.JavaScriptCore       	0x0047730e KJS::SourceElementsNode::execute(KJS::ExecState*) + 46
13  com.apple.JavaScriptCore       	0x004dae81 KJS::FunctionBodyNode::execute(KJS::ExecState*) + 417
14  com.apple.JavaScriptCore       	0x004e7e5f KJS::Interpreter::evaluate(KJS::UString const&, int, KJS::UChar const*, int, KJS::JSValue*) + 1887
15  com.apple.WebCore              	0x012ac6fa WebCore::KJSProxy::evaluate(WebCore::String const&, int, WebCore::String const&) + 202
16  com.apple.WebCore              	0x0146f76b WebCore::FrameLoader::executeScript(WebCore::String const&, int, WebCore::String const&) + 75
17  com.apple.WebCore              	0x0146f7da WebCore::FrameLoader::executeScript(WebCore::String const&, bool) + 58
18  com.apple.WebCore              	0x012b3ac2 KJS::ScheduledAction::execute(KJS::Window*) + 898
19  com.apple.WebCore              	0x012b3c2d KJS::Window::timerFired(KJS::DOMWindowTimer*) + 61
20  com.apple.WebCore              	0x012b3df8 KJS::DOMWindowTimer::fired() + 40
21  com.apple.WebCore              	0x012528b9 WebCore::TimerBase::fireTimers(double, WTF::Vector<WebCore::TimerBase*, (unsigned long)0> const&) + 137
22  com.apple.WebCore              	0x01252982 WebCore::TimerBase::sharedTimerFired() + 162
23  com.apple.WebCore              	0x01252094 WebCore::timerFired(__CFRunLoopTimer*, void*) + 68
24  com.apple.CoreFoundation       	0x9082d7e2 CFRunLoopRunSpecific + 3341
25  com.apple.CoreFoundation       	0x9082cace CFRunLoopRunInMode + 61
26  com.apple.HIToolbox            	0x92ded8d8 RunCurrentEventLoopInMode + 285
27  com.apple.HIToolbox            	0x92decfe2 ReceiveNextEventCommon + 385
28  com.apple.HIToolbox            	0x92dece39 BlockUntilNextEventMatchingListInMode + 81
29  com.apple.AppKit               	0x93273465 _DPSNextEvent + 572
30  com.apple.AppKit               	0x93273056 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 137
31  com.apple.Safari               	0x00006cea 0x1000 + 23786
32  com.apple.AppKit               	0x9326cddb -[NSApplication run] + 512
33  com.apple.AppKit               	0x93260d2f NSApplicationMain + 573
34  com.apple.Safari               	0x0005f54a 0x1000 + 386378
35  com.apple.Safari               	0x0005f471 0x1000 + 386161

Comment 10 David Kilzer (:ddkilzer) 2007-10-31 09:58:33 PDT
Confirmed with a local debug build of WebKit r27257 with Safari 3 Public Beta v. 3.0.3 (522.12.1) on Mac OS X 10.4.10 (8R218).

* STEPS TO REPRODUCE
1. Launch Safari/WebKit.
2. Go to URL:  http://digg.com/
3. Log in to digg.
4. Search for "Leopard".
5. On the story about replacing Leopard's Windows BSOD icon, click "Comments".
6. Use the mighty mouse scroll wheel to scroll the page, or just sit on the page for 15-20 seconds.  (I was scrolled to the captcha dialog to add a comment at the bottom of the page when it crashed.)

Console output:

ASSERTION FAILED: !HashTranslator::equal(KeyTraits::emptyValue(), key)
(./wtf/HashTable.h:407 Value* WTF::HashTable<Key, Value, Extractor, HashFunctions, Traits, KeyTraits>::lookup(const T&) [with T = unsigned int, HashTranslator = WTF::IdentityHashTranslator<unsigned int, std::pair<unsigned int, int>, WTF::IntHash<unsigned int> >, Key = unsigned int, Value = std::pair<unsigned int, int>, Extractor = WTF::PairFirstExtractor<std::pair<unsigned int, int> >, HashFunctions = WTF::IntHash<unsigned int>, Traits = WTF::PairHashTraits<WTF::HashTraits<unsigned int>, WTF::HashTraits<int32_t> >, KeyTraits = WTF::HashTraits<unsigned int>])
Segmentation fault

Comment 11 David Kilzer (:ddkilzer) 2007-10-31 09:59:21 PDT

*** This bug has been marked as a duplicate of 15747 ***