Bug 157494 - Modern IDB: Prevent the same transaction from being commited/aborted twice
Summary: Modern IDB: Prevent the same transaction from being commited/aborted twice
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Brady Eidson
URL:
Keywords:
Depends on:
Blocks: 149117 154968
  Show dependency treegraph
 
Reported: 2016-05-09 16:14 PDT by Brady Eidson
Modified: 2016-05-09 16:59 PDT (History)
3 users (show)

See Also:


Attachments
Patch (11.84 KB, patch)
2016-05-09 16:23 PDT, Brady Eidson
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brady Eidson 2016-05-09 16:14:56 PDT
Modern IDB: Prevent the same transaction from being commited/aborted twice

Rarely, due to page navigation or worker shutdown, a transaction might be either committed or aborted after it has already been committed or aborted.

I could not reproduce this with a targeted test case attempting to reproduce it, but it is showing up as a source of at least some of the mysterious flakes (https://bugs.webkit.org/show_bug.cgi?id=154968)

By detecting this situation and turning it into an explicit error, we'll turn at least some mysterious timeouts into errors that will then become more actionable.
Comment 1 Brady Eidson 2016-05-09 16:23:03 PDT
Created attachment 278455 [details]
Patch
Comment 2 WebKit Commit Bot 2016-05-09 16:59:08 PDT
Comment on attachment 278455 [details]
Patch

Clearing flags on attachment: 278455

Committed r200598: <http://trac.webkit.org/changeset/200598>
Comment 3 WebKit Commit Bot 2016-05-09 16:59:11 PDT
All reviewed patches have been landed.  Closing bug.