Bug 157341 - [GStreamer] Bump internal jhbuild versions to 1.8.0 and patches to support MSE
Summary: [GStreamer] Bump internal jhbuild versions to 1.8.0 and patches to support MSE
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Platform (show other bugs)
Version: WebKit Local Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 156695 (view as bug list)
Depends on:
Blocks: 157314
  Show dependency treegraph
 
Reported: 2016-05-04 03:33 PDT by Enrique Ocaña
Modified: 2016-12-28 05:33 PST (History)
2 users (show)

See Also:


Attachments
Patch (16.29 KB, patch)
2016-05-04 04:52 PDT, Enrique Ocaña
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Enrique Ocaña 2016-05-04 03:33:30 PDT
GStreamer 1.8.0 is a requirement for the Media Source Extensions patches coming soon (see https://bugs.webkit.org/show_bug.cgi?id=157314). Also, two custom patches for gst-plugins-good are needed:

- Revert "qtdemux: expose streams with first moof for fragmented format": This patch will be present in GStreamer 1.8.2. It's tracked in https://bugzilla.gnome.org/show_bug.cgi?id=764733

- Use the tfdt decode time when it's significantly different than the time in the last sample if always-honor-tfdt is enabled: This feature hasn't been upstreamed yet and may evolve in the future from a property in qtdemux to an automatic behaviour when a DISCONT flag is detected on incoming buffers, but by now this temporary implementation does its job. It's tracked in https://bugzilla.gnome.org/show_bug.cgi?id=754230

Note that in current WebKit trunk (http://trac.webkit.org/changeset/200031) there are already 29 tests that don't run as expected:

<pre>
Unexpected flakiness: timeouts (8)
  accessibility/media-controls.html [ Timeout Pass ]
  cssom/cssimportrule-media.html [ Timeout Pass ]
  fast/css/font-face-in-media-rule.html [ Timeout Pass ]
  fast/dom/StyleSheet/css-medialist-item.html [ Timeout Pass ]
  fast/dom/beforeload/clear-video-poster-in-beforeload-listener.html [ Timeout Pass ]
  fast/dom/css-mediarule-deleteRule-update.html [ Timeout Pass ]
  fast/events/media-element-focus-tab.html [ Timeout Pass ]
  media/track/track-in-band-subtitles-too-large.html [ Failure Timeout Missing ]

Regressions: Unexpected text-only failures (11)
  fast/hidpi/video-controls-in-hidpi.html [ Failure ]
  fast/layers/video-layer.html [ Failure ]
  fullscreen/video-controls-override.html [ Failure ]
  media/media-controls-drag-timeline-set-controls-property.html [ Failure ]
  media/media-source/media-source-sequence-timestamps.html [ Failure ]
  media/media-source/media-source-stpp-crash.html [ Failure ]
  media/media-source/media-source-timeoffset.html [ Failure ]
  media/track/track-manual-mode.html [ Failure ]
  media/track/video-track-alternate-groups.html [ Failure ]
  media/video-background-tab-playback.html [ Failure ]
  media/video-restricted-no-preload-metadata.html [ Failure ]

Regressions: Unexpected audio failures (4)
  webaudio/codec-tests/aac/vbr-128kbps-44khz.html [ Failure ]
  webaudio/codec-tests/vorbis/vbr-128kbps-44khz.html [ Failure ]
  webaudio/codec-tests/vorbis/vbr-70kbps-44khz.html [ Failure ]
  webaudio/codec-tests/vorbis/vbr-96kbps-44khz.html [ Failure ]

Regressions: Unexpected timeouts (4)
  fast/media/print-restores-previous-mediatype.html [ Timeout ]
  http/tests/security/contentSecurityPolicy/media-src-allowed.html [ Timeout ]
  media/media-source/media-source-loadedmetada-with-two-sourcebuffers.html [ Timeout ]
  media/video-load-preload-none.html [ Timeout ]

Regressions: Unexpected missing results (1)
  http/tests/security/mixedContent/resources/frame-with-insecure-audio-video.html [ Missing ]
</pre>
Comment 1 Enrique Ocaña 2016-05-04 04:52:41 PDT
Created attachment 278078 [details]
Patch
Comment 2 Enrique Ocaña 2016-05-04 04:56:18 PDT
I've run the layout tests with this patch and the following unexpected flakiness are not present anymore, compared to results on master (see bug description):

  accessibility/media-controls.html
  cssom/cssimportrule-media.html
  fast/css/font-face-in-media-rule.html
  fast/dom/StyleSheet/css-medialist-item.html
  fast/dom/beforeload/clear-video-poster-in-beforeload-listener.html
  fast/dom/css-mediarule-deleteRule-update.html
  fast/events/media-element-focus-tab.html

These unexpected flakiness are still present, compared to master:
  media/track/track-in-band-subtitles-too-large.html [ Failure Timeout Missing ]
  media/track/track-manual-mode.html [ Failure Timeout Pass ]
Comment 3 Xabier Rodríguez Calvar 2016-05-04 05:02:05 PDT
Comment on attachment 278078 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=278078&action=review

> Tools/ChangeLog:1
> +2016-05-04  Enrique Ocaña González  <eocanha@igalia.com>

There seem to be some encoding issues
Comment 4 Enrique Ocaña 2016-05-04 07:13:42 PDT
I think they're an issue in the pretty viewer. The raw viewer[1] looks fine, and I've submitted more patches with UTF-8 in the past (raw: [2], pretty with issues: [3]).

[1] https://bugs.webkit.org/attachment.cgi?id=278078&action=edit
[2] https://bugs.webkit.org/attachment.cgi?id=207629&action=edit
[3] https://bugs.webkit.org/attachment.cgi?id=207629&action=prettypatch
Comment 5 WebKit Commit Bot 2016-05-05 01:39:43 PDT
Comment on attachment 278078 [details]
Patch

Clearing flags on attachment: 278078

Committed r200454: <http://trac.webkit.org/changeset/200454>
Comment 6 WebKit Commit Bot 2016-05-05 01:39:47 PDT
All reviewed patches have been landed.  Closing bug.
Comment 7 Philippe Normand 2016-05-24 00:31:03 PDT
*** Bug 156695 has been marked as a duplicate of this bug. ***