Bug 15734 - fast/xpath/namespace-vs-predicate.xhtml fails unexpectedly in no-SVG build
Summary: fast/xpath/namespace-vs-predicate.xhtml fails unexpectedly in no-SVG build
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Major
Assignee: Alexey Proskuryakov
URL:
Keywords: Regression
Depends on:
Blocks:
 
Reported: 2007-10-28 05:29 PDT by Mark Rowe (bdash)
Modified: 2019-02-06 09:03 PST (History)
2 users (show)

See Also:


Attachments
unknown namespace test case (554 bytes, application/xhtml+xml)
2007-10-28 12:45 PDT, Alexey Proskuryakov
no flags Details
fix the test (1.28 KB, patch)
2007-12-28 12:27 PST, Alexey Proskuryakov
mitz: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Rowe (bdash) 2007-10-28 05:29:33 PDT
http://build.webkit.org/results/trunk-mac-intel-nosvg/2750/results.html shows that fast/xpath/namespace-vs-predicate.xhtml is failing on the no-SVG buildbot.  The actual output contains the following error:
CONSOLE MESSAGE: line 38: TypeError: Null value

This is emitted by the following line of code:
        // Remove this node from the document so it doesn't make the DumpRenderTree output
        // different when SVG is enabled and disabled.
        document.getElementById("r_00").parentNode.removeChild(document.getElementById("r_00"));

As the comment describes, this is intended to ensure that the <svg:g> node is removed to maintain identical rendering in SVG and no-SVG builds.  It is not clear why this is throwing an exception.
Comment 1 Alexey Proskuryakov 2007-10-28 10:22:35 PDT
Do you know when this regressed? I'm not quite sure what kind of a bug this is: Firefox seems to have a similar problem with elements in unknown namespaces.
Comment 2 Mark Rowe (bdash) 2007-10-28 10:28:38 PDT
Sorry I don't.  It's probably been like that for quite a while now.
Comment 3 Alexey Proskuryakov 2007-10-28 12:45:48 PDT
Created attachment 16916 [details]
unknown namespace test case

Firefox and TOT WebKit behave identically on this test (actually, Tiger WebKit does the same). I still don't see why.
Comment 4 Alexey Proskuryakov 2007-12-28 12:27:00 PST
Created attachment 18150 [details]
fix the test

It's actually clear: we do not support xml:id (see bug 16505), and plain "id" is only treated as ID in HTML and SVG content (unless a doctype says that some attribute is an ID, but it doesn't in this case, and we don't even support that, bug 12971).

A no-SVG build isn't supposed to know about SVG id attribute.
Comment 5 mitz 2007-12-28 12:33:10 PST
Comment on attachment 18150 [details]
fix the test

r=me
Comment 6 Alexey Proskuryakov 2007-12-28 23:52:33 PST
Committed revision 29024.

Comment 7 Lucas Forschler 2019-02-06 09:03:08 PST
Mass moving XML DOM bugs to the "DOM" Component.