Bug 157225 - Rename getAssignedNodes to assignedNodes and support flattened option
Summary: Rename getAssignedNodes to assignedNodes and support flattened option
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Ryosuke Niwa
Keywords: InRadar
Depends on:
Blocks: 148695
  Show dependency treegraph
Reported: 2016-04-29 20:00 PDT by Ryosuke Niwa
Modified: 2016-04-29 23:07 PDT (History)
7 users (show)

See Also:

Patch (27.84 KB, patch)
2016-04-29 20:24 PDT, Ryosuke Niwa
koivisto: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryosuke Niwa 2016-04-29 20:00:05 PDT
Update HTMLSlotElement.prototype.getAssignedNodes to match the latest spec.
Comment 1 Ryosuke Niwa 2016-04-29 20:24:28 PDT
Created attachment 277787 [details]
Comment 2 Antti Koivisto 2016-04-29 21:01:19 PDT
Comment on attachment 277787 [details]

View in context: https://bugs.webkit.org/attachment.cgi?id=277787&action=review

> Source/WebCore/html/HTMLSlotElement.cpp:110
> +        } else
> +            nodes.append(node);

I usually use continue rather than dangling else like this.
Comment 3 Ryosuke Niwa 2016-04-29 21:18:27 PDT
Committed r200285: <http://trac.webkit.org/changeset/200285>
Comment 4 Radar WebKit Bug Importer 2016-04-29 23:07:50 PDT