Bug 157160 - AX: [ATK] Expose elements with ARIA's "text" role
Summary: AX: [ATK] Expose elements with ARIA's "text" role
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Accessibility (show other bugs)
Version: WebKit Nightly Build
Hardware: All Linux
: P2 Normal
Assignee: Joanmarie Diggs (irc: joanie)
URL:
Keywords: InRadar
: 98359 117581 125506 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-04-28 18:00 PDT by Joanmarie Diggs (irc: joanie)
Modified: 2016-04-29 06:07 PDT (History)
11 users (show)

See Also:


Attachments
Patch (7.00 KB, patch)
2016-04-28 20:15 PDT, Joanmarie Diggs (irc: joanie)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Joanmarie Diggs (irc: joanie) 2016-04-28 18:00:07 PDT
Because WebCore Accessibility maps the ARIA "text" role StaticTextRole, we've been folding the content into the parent object like we would for a RenderText object. That's clearly wrong.
Comment 1 Joanmarie Diggs (irc: joanie) 2016-04-28 18:01:16 PDT
*** Bug 125506 has been marked as a duplicate of this bug. ***
Comment 2 Radar WebKit Bug Importer 2016-04-28 18:03:01 PDT
<rdar://problem/25994903>
Comment 3 Joanmarie Diggs (irc: joanie) 2016-04-28 18:06:30 PDT
*** Bug 117581 has been marked as a duplicate of this bug. ***
Comment 4 Joanmarie Diggs (irc: joanie) 2016-04-28 18:33:22 PDT
*** Bug 98359 has been marked as a duplicate of this bug. ***
Comment 5 Joanmarie Diggs (irc: joanie) 2016-04-28 20:15:32 PDT
Created attachment 277669 [details]
Patch
Comment 6 WebKit Commit Bot 2016-04-29 06:07:33 PDT
Comment on attachment 277669 [details]
Patch

Clearing flags on attachment: 277669

Committed r200240: <http://trac.webkit.org/changeset/200240>
Comment 7 WebKit Commit Bot 2016-04-29 06:07:39 PDT
All reviewed patches have been landed.  Closing bug.