Bug 15690 - Bug in layout test framework (setUpPage vs. setUpPageStatus)
Summary: Bug in layout test framework (setUpPage vs. setUpPageStatus)
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 16494 (view as bug list)
Depends on: 15707
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-25 09:36 PDT by Christian Hansen
Modified: 2009-02-23 06:48 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Hansen 2007-10-25 09:36:35 PDT
There seems to be a bug the test framework used by the layout tests.  Upon completion the setUpPage function overwrites itself when it really means to update setUpPageComplete.  I'm not sure exactly what the consequences are but in any case it seems wrong.
Comment 1 Christian Hansen 2007-10-25 10:51:33 PDT
Correction: not setUpPageComplete but setUpPageStatus.
Comment 2 Mark Rowe (bdash) 2007-10-25 19:10:00 PDT
Can you be more specific about this?
Comment 3 Christian Hansen 2007-10-25 21:18:50 PDT
If you run dom/xhtml/level2/html/HTMLIFrameElement11.xhtml an exception is thrown at selfxhtml.js:715 and the actual test is never run.  However, the test is still marked as passed for some reason.

Also, if you look at the code in HTMLIFrameElement11.js (or any of the others like it) I think it is pretty obvious that overwriting setUpPage is not the intended behavior.
Comment 4 Alexey Proskuryakov 2007-10-25 22:03:41 PDT
Here are the results for this test, I don't see it marked as passed:

Test	http://www.w3.org/2001/DOM-Test-Suite/level2/html/HTMLIFrameElement11
Status	failure
Message	titleLink: assertEquals failed, actual , expected NIST DOM HTML Test - FRAME.

Comment 5 Christian Hansen 2007-10-25 22:25:42 PDT
Sorry, I picked the wrong HTMLIFrameElement11 -- I meant dom/html/level2/html/HTMLIFrameElement11.html.  In safari 3.0.3 I get

Test:	http://www.w3.org/2001/DOM-Test-Suite/level2/html/HTMLIFrameElement11
Status:	Success

But an error shows up in the javascript console:

Value complete (result of expression setUpPage) is not object.
selfhtml.js:692
Comment 6 Alexey Proskuryakov 2007-10-25 23:35:58 PDT
Oh, that's a bad bug - thanks for catching it!

Interestingly, this particular test starts to crash for me when corrected :-(. I'm going to see if this can be easily fixed.
Comment 7 Christian Hansen 2007-10-26 00:00:23 PDT
Note that this is a potential problem for any test whose .js file was created from the same template, which I think is most of them.
Comment 8 Alexey Proskuryakov 2007-10-26 00:02:01 PDT
Yes, there were several thousand instances of this problem.

Filed <http://www.w3.org/Bugs/Public/show_bug.cgi?id=5227>, so that this could be fixed upstream, too.
Comment 9 Alexey Proskuryakov 2007-12-18 12:30:19 PST
*** Bug 16494 has been marked as a duplicate of this bug. ***
Comment 10 Feng Qian 2008-01-03 10:18:15 PST
The bug in w3c is marked as fixed. How can we down steam changes to WebKit?

(In reply to comment #9)
> *** Bug 16494 has been marked as a duplicate of this bug. ***
> 

(In reply to comment #8)
> Yes, there were several thousand instances of this problem.
> 
> Filed <http://www.w3.org/Bugs/Public/show_bug.cgi?id=5227>, so that this could
> be fixed upstream, too.
> 
Comment 11 Alexey Proskuryakov 2008-01-03 12:45:14 PST
We need to fix bug 15707, which blocks this one.
Comment 12 Alexey Proskuryakov 2009-02-23 06:48:44 PST
Fix committed r41140...r41145.