Bug 156786 - REGRESSION: Flexbox stops resizing vertically
Summary: REGRESSION: Flexbox stops resizing vertically
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: Safari Technology Preview
Hardware: Macintosh OS X 10.11
: P2 Major
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2016-04-20 01:32 PDT by Ricci Adams
Modified: 2016-10-20 01:01 PDT (History)
6 users (show)

See Also:


Attachments
HTML file demonstrating issue (7.22 KB, text/html)
2016-04-20 01:32 PDT, Ricci Adams
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ricci Adams 2016-04-20 01:32:51 PDT
Created attachment 276812 [details]
HTML file demonstrating issue

This is a bit hard to explain, but I've attached a reproducible reduction.

The attached HTML file creates a grid using flex box.  In response to a Window "resize" event, the grid is resized to fill the entire window.  Under Safari Technology Preview, the grid becomes stuck after the initial resize.

Steps to Reproduce:
1) Load the HTML in a web browser
2) Resize the window to be larger
3) The grid will snap to the new window size
4) Resize the window to be smaller

Expected Result:
In Safari 9, Chrome, and Firefox, the grid should continue to resize and fill the window on both the horizontal and vertical axis.

Actual Result:
In Safari Technology Preview and WebKit nightlies, each row in the grid becomes "stuck" after the initial resize, and won't shorten.  The grid continues to work in the horizontal axis.
Comment 1 Radar WebKit Bug Importer 2016-04-22 13:54:23 PDT
<rdar://problem/25884714>
Comment 2 Sergio Villar Senin 2016-05-19 04:36:43 PDT
Yeah looks like a bug. I'll try to take a look
Comment 3 Jon Lee 2016-06-02 20:01:37 PDT
Any update?
Comment 4 Sergio Villar Senin 2016-06-03 01:50:08 PDT
(In reply to comment #3)
> Any update?

No update I'm afraid. I'm really busy ATM with some other stuff so I don't think I could devote time to this bug in the following weeks.
Comment 5 Sergio Villar Senin 2016-10-20 01:01:36 PDT
I've tried this today and it seems it has been already fixed. Could you verify?