Bug 156699 - Web Inspector: Storage DataGrids have a half-pixel transparent/white border below the header
Summary: Web Inspector: Storage DataGrids have a half-pixel transparent/white border b...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Local Build
Hardware: All All
: P2 Normal
Assignee: Nikita Vasilyev
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2016-04-18 08:06 PDT by Timothy Hatcher
Modified: 2016-05-31 17:30 PDT (History)
11 users (show)

See Also:


Attachments
Screenshot (12.22 KB, image/png)
2016-04-18 08:06 PDT, Timothy Hatcher
no flags Details
[Image] Bug (66.28 KB, image/png)
2016-04-20 16:50 PDT, Nikita Vasilyev
no flags Details
WIP (1.27 KB, patch)
2016-04-20 18:48 PDT, Nikita Vasilyev
nvasilyev: commit-queue-
Details | Formatted Diff | Diff
[Image] Half pixel off (16.34 KB, image/png)
2016-04-29 17:45 PDT, Nikita Vasilyev
no flags Details
Patch (1.26 KB, patch)
2016-05-31 15:35 PDT, Nikita Vasilyev
buildbot: commit-queue-
Details | Formatted Diff | Diff
[Image] With patch applied (214.31 KB, image/png)
2016-05-31 15:37 PDT, Nikita Vasilyev
no flags Details
Archive of layout-test-results from ews107 for mac-yosemite-wk2 (1023.82 KB, application/zip)
2016-05-31 16:44 PDT, Build Bot
no flags Details
Patch (1.26 KB, patch)
2016-05-31 16:52 PDT, Nikita Vasilyev
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Timothy Hatcher 2016-04-18 08:06:56 PDT
Created attachment 276635 [details]
Screenshot

None of the other DataGrids have this issue (the grey border should butt up against the first row). This is likely a regression from the switch to half-pixel borders on tables.
Comment 1 Radar WebKit Bug Importer 2016-04-18 08:07:11 PDT
<rdar://problem/25778260>
Comment 2 Nikita Vasilyev 2016-04-20 16:50:39 PDT
Created attachment 276866 [details]
[Image] Bug

There is another issue with DataGrids' half-pixel borders.
They aren't aligned with the sidebar border.

As per discussed in person, we should just use 1px horizontal borders for now.
Comment 3 Nikita Vasilyev 2016-04-20 18:48:11 PDT
Created attachment 276880 [details]
WIP
Comment 4 Nikita Vasilyev 2016-04-20 18:54:06 PDT
Comment on attachment 276880 [details]
WIP

View in context: https://bugs.webkit.org/attachment.cgi?id=276880&action=review

> Source/WebInspectorUI/UserInterface/Views/DataGrid.css:82
> +    box-sizing: content-box;

This should not be necessary. However, without this, the table header is off
by half a pixel—it's 22.5 pixels tall. This is bizarre and could be a recent WebKit bug.
I'm working on a reduction for Zalan.
Comment 5 Nikita Vasilyev 2016-04-29 17:45:22 PDT
Created attachment 277766 [details]
[Image] Half pixel off

(In reply to comment #4)
> Comment on attachment 276880 [details]
> WIP
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=276880&action=review
> 
> > Source/WebInspectorUI/UserInterface/Views/DataGrid.css:82
> > +    box-sizing: content-box;
> 
> This should not be necessary. However, without this, the table header is off
> by half a pixel—it's 22.5 pixels tall. This is bizarre and could be a recent
> WebKit bug.
> I'm working on a reduction for Zalan.

This bug was introduced by bug 154437. However, reverting that
change does not fix the issue! See the attached screenshot.
Comment 6 BJ Burg 2016-04-29 21:07:52 PDT
Comment on attachment 276880 [details]
WIP

Is this patch ready for review? It's named 'WIP'. Clearing r? for now.
Comment 7 Nikita Vasilyev 2016-04-29 21:30:01 PDT
(In reply to comment #6)
> Comment on attachment 276880 [details]
> WIP
> 
> Is this patch ready for review? It's named 'WIP'. Clearing r? for now.

No, it isn't.

It does look like a bug in WebKit and I'm still working on a reduction.
Comment 8 Nikita Vasilyev 2016-05-31 15:30:22 PDT
(In reply to comment #5)
> Created attachment 277766 [details]
> [Image] Half pixel off

I cannot reproduce the issue on this screenshot any longer.
I assume it was a WebKit rendering bug and now it's 
fixed.
Comment 9 Nikita Vasilyev 2016-05-31 15:35:21 PDT
Created attachment 280190 [details]
Patch
Comment 10 Nikita Vasilyev 2016-05-31 15:37:56 PDT
Created attachment 280191 [details]
[Image] With patch applied
Comment 11 Build Bot 2016-05-31 16:44:12 PDT
Comment on attachment 280190 [details]
Patch

Attachment 280190 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.webkit.org/results/1414901

New failing tests:
fast/scrolling/scroll-container-horizontally.html
Comment 12 Build Bot 2016-05-31 16:44:15 PDT
Created attachment 280198 [details]
Archive of layout-test-results from ews107 for mac-yosemite-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews107  Port: mac-yosemite-wk2  Platform: Mac OS X 10.10.5
Comment 13 Nikita Vasilyev 2016-05-31 16:52:45 PDT
Created attachment 280200 [details]
Patch

Seems like an unrelated flaky test.
Comment 14 WebKit Commit Bot 2016-05-31 17:29:55 PDT
Comment on attachment 280200 [details]
Patch

Clearing flags on attachment: 280200

Committed r201540: <http://trac.webkit.org/changeset/201540>
Comment 15 WebKit Commit Bot 2016-05-31 17:30:01 PDT
All reviewed patches have been landed.  Closing bug.