Bug 15641 - REGRESSION(r25563): AJAX in Magnolia Authoring Interface Broken
Summary: REGRESSION(r25563): AJAX in Magnolia Authoring Interface Broken
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL: http://demoauthor.magnolia.info/.magn...
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2007-10-23 11:29 PDT by Sean McMains
Modified: 2008-07-28 13:54 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sean McMains 2007-10-23 11:29:38 PDT
To reproduce:

1. Go to http://demoauthor.magnolia.info/.magnolia/pages/adminCentral.html
2. Enter "superuser" for both username and password
3. Once page loads, click any of the navigation on the left side (Website, Documents, etc.)

Expected behavior: main section of page should load with appropriate content

Actual behavior: main section blanks out, but never loads with replacement content

This works correctly in the current release version of Safari
Comment 1 Matt Lilek 2007-10-23 13:21:19 PDT
Confirmed with r26922.
Comment 2 Matt Lilek 2007-10-23 13:56:34 PDT
bisect-builds tells me this regressed between r25552 and r25571.
Comment 3 Alexey Proskuryakov 2007-10-23 23:07:21 PDT
Rolling out <http://trac.webkit.org/projects/webkit/changeset/25563> fixes this.
Comment 4 David Kilzer (:ddkilzer) 2007-10-24 04:36:27 PDT
<rdar://problem/5556971>
Comment 5 Geoffrey Garen 2007-10-24 09:52:35 PDT
Doh!
Comment 6 David Kilzer (:ddkilzer) 2008-07-28 13:54:43 PDT
Works for me with WebKit nightly r35289.