Bug 15638 - SVGImage causes malloc errors to print to console on this page
Summary: SVGImage causes malloc errors to print to console on this page
Status: RESOLVED DUPLICATE of bug 16164
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://files.myopera.com/dstorey/expe...
Keywords: SVGHitList
Depends on:
Blocks: 12095
  Show dependency treegraph
 
Reported: 2007-10-23 00:26 PDT by Eric Seidel (no email)
Modified: 2007-11-28 12:20 PST (History)
0 users

See Also:


Attachments
Fix, seems to cause regression in fast/images/svg-as-tiled-background.html (23.60 KB, patch)
2007-10-27 12:54 PDT, Eric Seidel (no email)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2007-10-23 00:26:15 PDT
SVGImage causes malloc errors to print to console on this page

I had a fix for this and never checked it in.  The size() function should use valueAsPercent instead of valueInSpecifiedUnits() or whatever it's currently using.  Right now we're making buffers 10000 times larger than they should be when SVGs don't have a specified size.
Comment 1 Eric Seidel (no email) 2007-10-27 12:54:17 PDT
Created attachment 16903 [details]
Fix, seems to cause regression in fast/images/svg-as-tiled-background.html

I need to find out yet if fast/images/svg-as-tiled-background.html is really a regression.  Not sure why that starts to fail after this fix (or even if it's failing due to this fix or if I just have out-of-date successful results.
Comment 2 Eric Seidel (no email) 2007-11-28 12:20:56 PST
This was fixed by bug 16164.

*** This bug has been marked as a duplicate of 16164 ***