Bug 156180 - [Mac][iOS][NETWORK_SESSION] Unable to download BLOB URLs
Summary: [Mac][iOS][NETWORK_SESSION] Unable to download BLOB URLs
Status: RESOLVED DUPLICATE of bug 156099
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks: 156099
  Show dependency treegraph
 
Reported: 2016-04-04 13:41 PDT by Brent Fulgham
Modified: 2016-09-24 19:09 PDT (History)
7 users (show)

See Also:


Attachments
Simple blob test case (596 bytes, text/html)
2016-04-05 10:06 PDT, Brent Fulgham
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brent Fulgham 2016-04-04 13:41:52 PDT
When WebKit is build using NETWORK_SESSION, it is not possible to download BLOB URLs.

Steps to reproduce:

1. Open the attached test case "blob_download_test.html".
2. Right-click on the "WebKit Icon" link and download to a file.
3. Save the file somewhere.
4. You get a copy of the old Gold WebKit icon in you download folder.
5. Right-click on the "Silly Blob Example" link and download to a file.
6. Save the file somewhere.
7. Nothing happens!
Comment 1 Brent Fulgham 2016-04-04 13:45:57 PDT
If you attach to the Network Process, you will see that the download fails:

NetworkLoad::didCompleteWithError.

The error object has a 0 error code, a nullptr PlatformError, and a blank failing URL.
Comment 2 Radar WebKit Bug Importer 2016-04-04 13:46:50 PDT
<rdar://problem/25536266>
Comment 3 Brent Fulgham 2016-04-05 10:06:18 PDT
Created attachment 275673 [details]
Simple blob test case
Comment 4 Alex Christensen 2016-05-09 09:28:42 PDT
Does this work without using NETWORK_SESSION?
Comment 5 Chris Dumez 2016-09-24 19:09:20 PDT

*** This bug has been marked as a duplicate of bug 156099 ***