Bug 15594 - Paths with markers have wrong repaint rects
Summary: Paths with markers have wrong repaint rects
Status: RESOLVED DUPLICATE of bug 33012
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.w3.org/Graphics/SVG/Test/2...
Keywords: HasReduction
Depends on:
Blocks:
 
Reported: 2007-10-21 11:57 PDT by Eric Seidel (no email)
Modified: 2009-12-30 12:03 PST (History)
1 user (show)

See Also:


Attachments
test case (861 bytes, image/svg+xml)
2007-10-21 12:33 PDT, Eric Seidel (no email)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2007-10-21 11:57:58 PDT
Paths with markers have too large of repaint rects

View 
http://www.w3.org/Graphics/SVG/Test/20030813/svggen/painting-marker-02-f.svg

and then try inspecting one of the paths with markers.  You'll notice that the rect the inspector highlights is huge!  (Another way to demonstrate this would be to animate a path with a marker via. js and then watch the repaint rects in Quartz Debug.)
Comment 1 Eric Seidel (no email) 2007-10-21 12:33:13 PDT
Created attachment 16770 [details]
test case
Comment 2 Dirk Schulze 2009-12-30 12:03:55 PST

*** This bug has been marked as a duplicate of bug 33012 ***