RESOLVED FIXED 155743
Reduce PassRefPtr uses in editing
https://bugs.webkit.org/show_bug.cgi?id=155743
Summary Reduce PassRefPtr uses in editing
Gyuyoung Kim
Reported 2016-03-21 23:07:55 PDT
SSIA.
Attachments
Patch (24.30 KB, patch)
2016-03-21 23:15 PDT, Gyuyoung Kim
no flags
Patch (38.37 KB, patch)
2016-03-22 22:28 PDT, Gyuyoung Kim
no flags
Patch (38.37 KB, patch)
2016-03-23 01:13 PDT, Gyuyoung Kim
no flags
Patch (39.15 KB, patch)
2016-03-23 04:26 PDT, Gyuyoung Kim
no flags
Gyuyoung Kim
Comment 1 2016-03-21 23:15:35 PDT
Darin Adler
Comment 2 2016-03-22 09:13:16 PDT
Comment on attachment 274643 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=274643&action=review > Source/WebCore/ChangeLog:8 > + Use RefPtr<>&& or raw pointer in arugment instaed of PassRefPtr. Typo: instead > Source/WebCore/editing/CompositeEditCommand.h:143 > + void wrapContentsInDummySpan(Element*); Should take Element&. > Source/WebCore/editing/TextInsertionBaseCommand.h:43 > + static void applyTextInsertionCommand(Frame*, TextInsertionBaseCommand*, const VisibleSelection& selectionForInsertion, const VisibleSelection& endingSelection); Should take TextInsertionBaseCommand&. > Source/WebCore/editing/TypingCommand.h:105 > + static RefPtr<TypingCommand> lastTypingCommandIfStillOpenForTyping(Frame*); Should take a Frame&. > Source/WebCore/editing/WrapContentsInDummySpanCommand.h:37 > + static Ref<WrapContentsInDummySpanCommand> create(Element* element) Should take an Element&. > Source/WebCore/editing/WrapContentsInDummySpanCommand.h:43 > + explicit WrapContentsInDummySpanCommand(Element*); Should take an Element&. > Source/WebCore/editing/htmlediting.cpp:992 > + return createTabSpanElement(document, RefPtr<Node>()); I think we should write nullptr or { } here instead of RefPtr<Node>(). > Source/WebCore/editing/markup.cpp:521 > + return WTFMove(style); Should not need WTFMove here because of the return value optimization. > Source/WebCore/editing/markup.cpp:900 > + return WTFMove(fragment); Should not need WTFMove here because of the return value optimization. > Source/WebCore/editing/markup.cpp:978 > + return WTFMove(fragment); Should not need WTFMove here because of the return value optimization. > Source/WebCore/editing/markup.h:54 > +RefPtr<DocumentFragment> createFragmentForInnerOuterHTML(const String&, Element*, ParserContentPolicy, ExceptionCode&); Should take Element&. That argument should be first, not after the string. Also seems that the String argument should be named. > Source/WebCore/editing/markup.h:55 > +RefPtr<DocumentFragment> createFragmentForTransformToFragment(const String&, const String& sourceMIMEType, Document* outputDoc); Should take Document&. Argument name “outputDoc” is not helpful, should be Document&, should be first argument like in createFragmentFromMarkup above. Also seems that the String argument should be named. > Source/WebCore/editing/markup.h:56 > +RefPtr<DocumentFragment> createContextualFragment(const String&, HTMLElement*, ParserContentPolicy, ExceptionCode&); Should take HTMLElement&. That argument should be first, not after the string. Also seems that the String argument should be named.
Gyuyoung Kim
Comment 3 2016-03-22 22:28:43 PDT
Gyuyoung Kim
Comment 4 2016-03-22 22:32:24 PDT
(In reply to comment #2) > Comment on attachment 274643 [details] > Patch > > View in context: > https://bugs.webkit.org/attachment.cgi?id=274643&action=review > > > Source/WebCore/ChangeLog:8 > > + Use RefPtr<>&& or raw pointer in arugment instaed of PassRefPtr. > > Typo: instead > > > Source/WebCore/editing/CompositeEditCommand.h:143 > > + void wrapContentsInDummySpan(Element*); > > Should take Element&. > > > Source/WebCore/editing/TextInsertionBaseCommand.h:43 > > + static void applyTextInsertionCommand(Frame*, TextInsertionBaseCommand*, const VisibleSelection& selectionForInsertion, const VisibleSelection& endingSelection); > > Should take TextInsertionBaseCommand&. > > > Source/WebCore/editing/TypingCommand.h:105 > > + static RefPtr<TypingCommand> lastTypingCommandIfStillOpenForTyping(Frame*); > > Should take a Frame&. > > > Source/WebCore/editing/WrapContentsInDummySpanCommand.h:37 > > + static Ref<WrapContentsInDummySpanCommand> create(Element* element) > > Should take an Element&. > > > Source/WebCore/editing/WrapContentsInDummySpanCommand.h:43 > > + explicit WrapContentsInDummySpanCommand(Element*); > > Should take an Element&. > > Source/WebCore/editing/markup.cpp:521 > > + return WTFMove(style); > > Should not need WTFMove here because of the return value optimization. > > > Source/WebCore/editing/markup.cpp:900 > > + return WTFMove(fragment); > > Should not need WTFMove here because of the return value optimization. > > > Source/WebCore/editing/markup.cpp:978 > > + return WTFMove(fragment); > > Should not need WTFMove here because of the return value optimization. > > > Source/WebCore/editing/markup.h:54 > > +RefPtr<DocumentFragment> createFragmentForInnerOuterHTML(const String&, Element*, ParserContentPolicy, ExceptionCode&); > > Should take Element&. That argument should be first, not after the string. > Also seems that the String argument should be named. > > > Source/WebCore/editing/markup.h:55 > > +RefPtr<DocumentFragment> createFragmentForTransformToFragment(const String&, const String& sourceMIMEType, Document* outputDoc); > > Should take Document&. Argument name “outputDoc” is not helpful, should be > Document&, should be first argument like in createFragmentFromMarkup above. > Also seems that the String argument should be named. > > > Source/WebCore/editing/markup.h:56 > > +RefPtr<DocumentFragment> createContextualFragment(const String&, HTMLElement*, ParserContentPolicy, ExceptionCode&); > > Should take HTMLElement&. That argument should be first, not after the > string. Also seems that the String argument should be named. Thank you for your detailed review ! Fixed.
Gyuyoung Kim
Comment 5 2016-03-23 01:13:05 PDT
Gyuyoung Kim
Comment 6 2016-03-23 04:26:40 PDT
WebKit Commit Bot
Comment 7 2016-03-23 07:05:56 PDT
Comment on attachment 274742 [details] Patch Clearing flags on attachment: 274742 Committed r198583: <http://trac.webkit.org/changeset/198583>
WebKit Commit Bot
Comment 8 2016-03-23 07:06:01 PDT
All reviewed patches have been landed. Closing bug.
Alexey Proskuryakov
Comment 9 2016-03-23 11:03:34 PDT
Comment on attachment 274742 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=274742&action=review > Source/WebCore/editing/VisibleSelection.cpp:223 > + return WTFMove(searchRange); This is not right - moving the result is bad for performance, as it prevents copy elision. Some versions of compilers warn about that, breaking the build. Fixed in r198587.
Gyuyoung Kim
Comment 10 2016-03-23 17:35:13 PDT
(In reply to comment #9) > Comment on attachment 274742 [details] > Patch > > View in context: > https://bugs.webkit.org/attachment.cgi?id=274742&action=review > > > Source/WebCore/editing/VisibleSelection.cpp:223 > > + return WTFMove(searchRange); > > This is not right - moving the result is bad for performance, as it prevents > copy elision. Some versions of compilers warn about that, breaking the build. > > Fixed in r198587. Thanks for fixing it.
Note You need to log in before you can comment on or make changes to this bug.