Purge PassRefPtr from WebCore/html/shadow.
Created attachment 274514 [details] Patch
Comment on attachment 274514 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=274514&action=review I prefer the name tryCreate to maybeCreate. The name "maybe create" makes it sound like the decision of whether to create or not is a policy choice. But it’s not, it’s an error handling strategy, and "try create" expresses that more clearly. > Source/WebCore/html/shadow/MediaControlsApple.cpp:511 > + Ref<EventListener> listener = eventListener(); I see no reason for this local variable to be a Ref<EventListener> instead of EventListener&.
Created attachment 274527 [details] Patch for landing
Comment on attachment 274514 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=274514&action=review I changed maybeCreateFoo to tryCreateFoo where it just handles null error case. >> Source/WebCore/html/shadow/MediaControlsApple.cpp:511 >> + Ref<EventListener> listener = eventListener(); > > I see no reason for this local variable to be a Ref<EventListener> instead of EventListener&. I changed this to EventListener& instead.
Comment on attachment 274527 [details] Patch for landing Clearing flags on attachment: 274527 Committed r198473: <http://trac.webkit.org/changeset/198473>
All reviewed patches have been landed. Closing bug.