Bug 155580 - ASSERTION FAILED: rendererMappedResult == result in RenderGeometryMap::mapToContainer
Summary: ASSERTION FAILED: rendererMappedResult == result in RenderGeometryMap::mapToC...
Status: RESOLVED DUPLICATE of bug 151030
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-17 01:32 PDT by Fujii Hironori
Modified: 2016-03-18 11:11 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fujii Hironori 2016-03-17 01:32:08 PDT
ASSERTION FAILED: rendererMappedResult == result in RenderGeometryMap::mapToContainer

Reported in Bug 153576 Comment 10:

> This assertion fails after logging in on drive.google.com.  The values are
> close, but not equal.


A solution is suggested in Bug 153576 Comment 2:

> Maybe we can use something like:
> 
> ASSERT((rendererMappedResult - result).lengthSquared() < some_epsilon);
Comment 1 Said Abou-Hallawa 2016-03-18 11:11:19 PDT
I am not sure why this bug was logged. The original bug https://bugs.webkit.org/show_bug.cgi?id=153576 should have been reopened since it did not fix the issue completely.

The bug https://bugs.webkit.org/show_bug.cgi?id=151030 is about the same issue; it is older but it did have a test case which repro the bug with http://trac.webkit.org/changeset/196052. So I am resolving this one as a dupe of https://bugs.webkit.org/show_bug.cgi?id=151030.

*** This bug has been marked as a duplicate of bug 151030 ***