Allow clients to hide the accessory view on a form input session. Patch forthcoming.
Created attachment 274253 [details] patch v1
Comment on attachment 274253 [details] patch v1 View in context: https://bugs.webkit.org/attachment.cgi?id=274253&action=review r=me I am not setting cq+, in case you are inspired to change the name before committing this, but I’m fine with going with this name, and possibly changing it later. > Source/WebKit2/UIProcess/API/Cocoa/_WKFormInputSession.h:45 > +@property (nonatomic) BOOL hidesAccessoryView WK_AVAILABLE(NA, WK_IOS_TBA); This can be named better, but I don’t have a great suggestion. The things that I don’t like about this name are (a) an input session isn’t really a thing that hides (or shows) the accessory view (b) it’s strange to treat the accessory view as something that’s there by default and the input session can hide, but I understand how it would be misleading to name this property showsAccessoryView, because the accessory view isn’t shown for all input types. Here’s a not-so-great suggestion: // Defaults to YES. @property BOOL accessoryViewMayShow;
Created attachment 276882 [details] patch v2 with name change
Comment on attachment 276882 [details] patch v2 with name change Clearing flags on attachment: 276882 Committed r199823: <http://trac.webkit.org/changeset/199823>
All reviewed patches have been landed. Closing bug.